Bug 65510 - Nonexistant fonts in xdm/Xresources
Nonexistant fonts in xdm/Xresources
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-26 05:40 EDT by Zvi Har'El
Modified: 2007-04-18 12:42 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-27 12:06:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Zvi Har'El 2002-05-26 05:40:36 EDT
Description of Problem:
/usr/X11R6/lib/X11/xdm/Xresources specifies bad average width for fonts which
does not exists in the distribution

xlogin*font: -adobe-helvetica-medium-r-normal--12-120-75-75-p-69-iso8859-1
xlogin*promptFont: -adobe-helvetica-bold-r-normal--12-120-75-75-p-69-iso8859-1

The average width 69 is wrong. Should be 67 and 70 for the medium and bold
fonts, respectively.



-------------------------------------------------

Version-Release number of selected component (if applicable):
XFree86-xdm-4.2.0-8
XFree86-75dpi-fonts-4.2.0-8
--------------------------------------------------


How Reproducible:
screen width should be <= 800
-------------------------------------------------

Steps to Reproduce:
1. xlsfonts  -adobe-helvetica-medium-r-normal--12-120-75-75-p-69-iso8859-1
2. xlsfonts  -adobe-helvetica-medium-r-normal--12-120-75-75-p-*-iso8859-1
3. 
-------------------

Actual Results:
step 1 produces
Xlsfonts: pattern "-adobe-helvetica-medium-r-normal--12-120-75-75-p-69-iso8859-1"
unmatched.

step 2 produces 

-adobe-helvetica-medium-r-normal--12-120-75-75-p-67-iso8859-1
------------------------------

Expected Results:


Both steps should match the fully specified font.

--------------------------------------------------------------------

Additional Information:
	
Suggest to replace 69 (averagre width) *, for all the fonts in this file, so
they all look like ....-p-*-iso8859-1

BTW, On systems that have URW fonts (it is not in redhat linux 7.3 distribution)
the problem does not arise, since the type 1 fonts n019003l.pfb and n019004l.pfb
are used in this case to give the requested width.
Comment 1 Zvi Har'El 2002-05-26 08:26:56 EDT
About the URW fonts, RedHat7.3 do supply them in urw-fonts.2.0-17. However, the
file /usr/share/fonts/default/Type1/fonts.dir has the foundry specified as URW
rather then Adobe, e.g., 
n019003l.pfb -URW-Helvetica-medium-r-normal--0-0-0-0-p-0-iso8859-1
n019004l.pfb -URW-Helvetica-bold-r-normal--0-0-0-0-p-0-iso8859-1

which cannot be used by Xresources, unless again the font pattern is changed to 
-*-helvetica-....

Only fonts supplied in http://www.gimp.org/urw-fonts.tar.gz have a fonts.dir
which specifies adobe as the foundry (in addition to a fonts.dir_fndry_is_urw
file which specifies urw as the foundry)

# xlsfonts -fn "-*-helvetica-bold-r-normal--12-120-75-75-p-*-iso8859-1"
-adobe-helvetica-bold-r-normal--12-120-75-75-p-0-iso8859-1
-adobe-helvetica-bold-r-normal--12-120-75-75-p-70-iso8859-1
-urw-helvetica-bold-r-normal--12-120-75-75-p-0-iso8859-1
Comment 2 Mike A. Harris 2002-05-27 10:35:37 EDT
fonts.dir files are created at install time by mkfontdir.  Any font packages
which install premade fonts.dir files or which use hand edited fonts.dir
files will break miserably when mkfontdir gets ran by automated processes.

If our XFree86 font packages have fonts.dir problems, then XFree86 itself
has these problems, and not just the Red Hat distribution.  In this case,
it is something that should be fixed by XFree86.org upstream so that
every distribution can benefit from the fix, and also so that the people
who know this stuff best can ensure that the fix is both correct, and also
doesn't cause problems.

Please email your bug report to xpert@xfree86.org, xfree86@xfree86.org, and
your suggested fixes to fixes@xfree86.org

I will apply the change once it is integrated into XFree86 CVS and/or
accepted as correct by the XFree86 team.  I'll leave this report open and
in NEEDINFO state for now.
core team,
Comment 3 Zvi Har'El 2002-05-27 12:06:22 EDT
As I described it, the problem is in /etc/X11/xdm/Xresources, not in any of the
fonts.dir. The fonts selected there do not exist in the redhat distribution. I
didn't check any standard XFree86 distribution. There fore, I suggested the fix
to /etc/X11/xdm/Xresources could be done bu redhat. If you disapprove, I'll look
into the possiblility of notifying the mainteainers of XFree86. I beleive that
since most of redhat users install gdm, they will notice the problem in xdm, but
xdm configuration should be correct.
Comment 4 Mike A. Harris 2002-08-07 22:43:15 EDT
This change needs to be overviewed and accepted into XFree86.org sources,
as I do not see it as necessary, and there hasn't been anyone else report
this as a problem to us.

Note You need to log in before you can comment on or make changes to this bug.