Bug 655102 - package install tasks backed up after a failure
Summary: package install tasks backed up after a failure
Keywords:
Status: CLOSED DUPLICATE of bug 655851
Alias: None
Product: Pulp
Classification: Retired
Component: z_other
Version: unspecified
Hardware: Unspecified
OS: Linux
high
high
Target Milestone: ---
: ---
Assignee: Jeff Ortel
QA Contact: Preethi Thomas
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-11-19 15:59 UTC by dgao
Modified: 2011-07-15 19:30 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-01-05 20:14:32 UTC


Attachments (Terms of Use)

Description dgao 2010-11-19 15:59:41 UTC
Encountered after package install failure on consumergroup.

All subsequent package install command would hang indefinitely.

[root@pulp-qe ~]# pulp-admin package install --consumerid=foo -n patb
Created task id: c5dbc1c0-f3f2-11df-8913-5452001e3352
...................................................................................................... 

Tailing /var/log/pulp/pulp.log reveals that the task is not being created. Immediately after restarting goferd, all the backed up tasks get flushed and executed.

This issue cannot be reproduced deterministically at the moment, but is frequently encountered during nightly automation run.

Comment 1 Jeff Ortel 2010-12-06 16:21:05 UTC
I'm struggling to reproduce this but I'll keep trying.

(In reply to comment #0)
> Encountered after package install failure on consumergroup.
> 
> All subsequent package install command would hang indefinitely.
> 
> [root@pulp-qe ~]# pulp-admin package install --consumerid=foo -n patb
> Created task id: c5dbc1c0-f3f2-11df-8913-5452001e3352
> ...................................................................................................... 
> 
> Tailing /var/log/pulp/pulp.log reveals that the task is not being created.
> Immediately after restarting goferd, all the backed up tasks get flushed and
> executed.

If no task is being created on the server, then no requests are being sent to the agent.  So, I wonder how bouncing goferd would help?  On another note: Do you see anything in the gofer/agent.log that would indicate that yum is hanging and tying up the agent?

Comment 2 Jeff Ortel 2011-01-05 20:14:32 UTC

*** This bug has been marked as a duplicate of bug 655851 ***


Note You need to log in before you can comment on or make changes to this bug.