Bug 655118 - prevent extract clobbering $GLOBALS
Summary: prevent extract clobbering $GLOBALS
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: php
Version: 6.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Joe Orton
QA Contact: BaseOS QE - Apps
URL:
Whiteboard:
Keywords: Regression
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-11-19 16:37 UTC by Joe Orton
Modified: 2011-05-19 13:41 UTC (History)
2 users (show)

(edit)
Clone Of:
: 655330 (view as bug list)
(edit)
Last Closed: 2011-05-19 13:41:11 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:0615 normal SHIPPED_LIVE php bug fix and enhancement update 2011-05-18 17:56:16 UTC

Description Joe Orton 2010-11-19 16:37:13 UTC
Description:
extract() should not be able to clobber $GLOBALS.  This was
fixed as a part of the patch for CVE-2005-3390 (and upstream)
but regressed sometime after 5.1.x upstream.

Version: 
php-5.3.2-6.el6

Comment 10 errata-xmlrpc 2011-05-19 13:41:11 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0615.html


Note You need to log in before you can comment on or make changes to this bug.