Bug 65513 - OpenGL screen saver modules not supported w/XFree86 3.3.6
OpenGL screen saver modules not supported w/XFree86 3.3.6
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-26 11:45 EDT by Joachim Frieben
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-28 11:39:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joachim Frieben 2002-05-26 11:45:40 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020513

Description of problem:
It seems that "OpenGL" based "xscreensaver" modules are not compatible with
"XFree86-3.3.6" based "X" servers any more. This is a major inconvenience,
because "XFree86-4.*.*" does not always work properly with not so recent
graphics boards. In my case, it is an Intel 740 based 8 MB AGP card (not
excessively oldfashioned by the way).

Version-Release number of selected component (if applicable):
3.33-4

How reproducible:
Always

Steps to Reproduce:
1. Open "xscreensaver" configuration window.
2. Choose some "OpenGL" based module.

	

Actual Results:  1. Preview window remains empty, locking the screen leads to
some error messages on the display as mentioned in 2.
2. The file ".xsession-errors" exhibits the following message ("rubik" module
selected):

 "rubik: display ":0.0" does not support the GLX extension.
  Xlib:  extension "GLX" missing on display ":0.0"."

Expected Results:  The screen saver module should behave properly.

Additional info:
Comment 1 Bill Nottingham 2002-05-28 11:39:33 EDT
This is a problem with the libGL shipped with XFree86.
Comment 2 Mike A. Harris 2002-05-30 01:25:08 EDT
OpenGL will no longer work with any XFree86 3.3.6 server.  Previous releases
of Red Hat Linux had a separate Mesa release which was seriously hacked to
pieces to be able to provide software OpenGL support for non-GLX capable
X servers (3.3.6).  Maintaining this was a serious nightmare, and a lot of
development work to update Mesa with each new XFree86 release.  It also
caused a build dependancy loop between Mesa and XFree86, where both required
the other to build, and so I had to build Mesa, then X, install both, then
rebuild both again with any major update of either one of them.

The development overhead of continuing to support Mesa in that manner was
too great.  As such, for this release it was deemed best to use the Mesa
that comes with XFree86 integrated instead - which has also resulted in
a lot less bug reports.  In order to support 3.3.6 I began work on adding
fakeglx from Mesa 4 (backporting it), but due to various bugs that came up
in testing, and other development issues, I was unable to complete the
fakeglx backport in a working manner in time for our release (done in my
spare time, in an attempt to keep OpenGL support for 3.3.6 users).

During our entire beta cycle, not a single bug report or email concerning
this showed up at all, so I considered the impact to be much smaller than
I had initially considered when I decided to do this work in my spare
time.  The end result however, is a much more sane and stable OpenGL
installation for 4.x users, with less bugs, and dramatically reduced
development time, and packaging simplification.  In short, the inconvenience
caused by the lack of support, was outweighed by the benefits gained by
dropping support.  I've considered finishing off the fakeglx stuff and
possibly releasing it as an update, but I think now that time would be
better spent on more pressing issues with newer hardware, etc.

Also we've deprecated XFree86 3.3.6 for 2 or 3 releases now, and kept it
around only to maximize the longevity of older hardware for users.  We
cannot support 3.3.6 indefinitely - even if 4.x doesn't support various
hardware that 3.3.6 does - the maintenance overhead is just to great to
make it worthwhile.

What is much more important to us, to our users, and to the community, is
to find out what problems that 4.x has, and fix those issues if possible.

So, personally, if the i740 driver has issues needing attention, I would
ask that you please file bug reports on the problems that happen in the
4.2.0 i740 driver, so we can try to find fixes and/or workarounds for
them.  I actually have an i740 to play with, so I can try to reproduce
any problems you may have.  Please file 4.2.0 bug reports for these issues.



Comment 3 Joachim Frieben 2002-06-03 06:12:51 EDT
Wow, I am overwhelmed by your "pedagogical" effort - thanks a lot! I was of 
course aware that the lack of OpenGL support for 3.x.x servers was due to the 
removal of Mesa from Red Hat Linux 7.3, and I completely share your point of 
view concerning the priority of current components of Red Hat Linux such as 
XFree86-4.x.x.
I will thus post a bug report for XFree86-4.0.2 in conjunction with the INTEL 
740 AGP chip. Bye, and keep on the good work!

Note You need to log in before you can comment on or make changes to this bug.