Bug 655193 - Exclude ccache and squid directories from locate
Summary: Exclude ccache and squid directories from locate
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: mlocate
Version: 14
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
Assignee: Miloslav Trmač
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-11-19 20:27 UTC by Steve Snyder
Modified: 2010-11-23 22:43 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-11-23 22:43:04 UTC


Attachments (Terms of Use)
Exclude ccache and squid cache directories (421 bytes, patch)
2010-11-19 20:27 UTC, Steve Snyder
no flags Details | Diff

Description Steve Snyder 2010-11-19 20:27:20 UTC
Created attachment 461644 [details]
Exclude ccache and squid cache directories

Description of problem:

The ccache and squid applications generate a large number of data files with encoded names.  Because these names are not meaningful to humans, it is pointless to swell the mlocate database with data that won't be used.

Version-Release number of selected component (if applicable):

mlocate-0.23.1-1.fc14.1

How reproducible:

Always.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

See attached patch.

Comment 1 Miloslav Trmač 2010-11-23 21:53:46 UTC
Thanks for your report.

The default configuration already includes /var/cache/ccache and /var/spool/squid in PRUNEPATHS in /etc/updatedb.conf.  Is this not working or not sufficient?

Comment 2 Steve Snyder 2010-11-23 22:43:04 UTC
Oops!  I didn't realize there were exclusions in /etc/updatedb.conf.  I was just looking at the cron job.

Sorry to bother you.


Note You need to log in before you can comment on or make changes to this bug.