Bug 655212 - RandR 1.3 panning doesn't work
Summary: RandR 1.3 panning doesn't work
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: xorg-x11-server
Version: 6.0
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: rc
: ---
Assignee: Adam Jackson
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks: 713024
TreeView+ depends on / blocked
 
Reported: 2010-11-19 21:36 UTC by Felix Kuehling
Modified: 2011-12-06 14:38 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Panning was broken in RHEL 6.1. Users could no longer configure panning modes on the X server using randr. Patch was taking from upstream to fix. Panning works for users.
Clone Of:
: 710191 (view as bug list)
Environment:
RHEL 6, Radeon graphics
Last Closed: 2011-12-06 14:38:29 UTC
Target Upstream Version:


Attachments (Terms of Use)
Xorg.0.log (87.71 KB, text/plain)
2010-11-29 18:59 UTC, Felix Kuehling
no flags Details
Xorg.9.log (29.55 KB, text/plain)
2010-11-29 19:00 UTC, Felix Kuehling
no flags Details
dmesg output (73.25 KB, text/plain)
2010-11-29 19:00 UTC, Felix Kuehling
no flags Details
/var/log/messages (1.04 MB, text/plain)
2010-11-29 19:01 UTC, Felix Kuehling
no flags Details
710191 (RandR 1.3 panning doesn't work on Fedora) (50 bytes, text/plain)
2011-06-26 21:59 UTC, Ganapathi Kamath
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2011:1602 normal SHIPPED_LIVE xorg-x11-server and tigervnc bug fix and enhancement update 2011-12-06 00:51:12 UTC

Description Felix Kuehling 2010-11-19 21:36:09 UTC
Description of problem:
Panning with RandR 1.3 doesn't work. The "xrandr --output ... --panning ..." command resizes the desktop, but the mouse pointer can't be moved beyond the visible part of the desktop. Thus panning is impossible.


Version-Release number of selected component (if applicable):
xorg-x11-server-Xorg-1.7.7-26.el6.x86_64


How reproducible:
Steps to Reproduce:
1. Open a terminal
2. run "xrandr", not the output name of the connected monitor (e.g. DVI-1)
3. xrandr --output DVI-1 --panning 2000x2000 (something bigger than the current mode)
4. move the mouse pointer to try panning
  
Actual results:
xrandr --output DVI-1 --panning 2000x2000 resizes the screen as expected. But the mouse pointer can't be moved beyond the visible part of the desktop. So panning is impossible.

Expected results:
Panning to the currently invisible part of the desktop should be possible when the mouse is moved past the edge of the viewport.

Additional info:
Reproduced with radeon and fglrx drivers on multiple systems.
Panning works on other Linux distributions with Xserver 1.7.

Comment 2 Matěj Cepl 2010-11-29 10:42:24 UTC
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please add drm.debug=0x04 to the kernel command line, restart computer (with free source drivers, please), and attach

* your X server config file (/etc/X11/xorg.conf, if available),
* X server log file (/var/log/Xorg.*.log)
* output of the dmesg command, and
* system log (/var/log/messages)

to the bug report as individual uncompressed file attachments using the bugzilla file attachment link above.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.

Comment 3 Felix Kuehling 2010-11-29 18:59:54 UTC
Created attachment 463549 [details]
Xorg.0.log

Xorg.0.log using the free Radeon driver

Comment 4 Felix Kuehling 2010-11-29 19:00:32 UTC
Created attachment 463550 [details]
Xorg.9.log

Xorg.9.log. It's several days old but included for completeness.

Comment 5 Felix Kuehling 2010-11-29 19:00:56 UTC
Created attachment 463551 [details]
dmesg output

Comment 6 Felix Kuehling 2010-11-29 19:01:21 UTC
Created attachment 463552 [details]
/var/log/messages

Comment 7 RHEL Program Management 2011-01-07 04:29:14 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.

Comment 8 Suzanne Yeghiayan 2011-01-07 16:20:15 UTC
This request was erroneously denied for the current release of Red Hat
Enterprise Linux.  The error has been fixed and this request has been
re-proposed for the current release.

Comment 9 RHEL Program Management 2011-02-01 05:58:49 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.

Comment 10 RHEL Program Management 2011-02-01 18:53:13 UTC
This request was erroneously denied for the current release of
Red Hat Enterprise Linux.  The error has been fixed and this
request has been re-proposed for the current release.

Comment 13 Vladimir Benes 2011-05-26 09:32:46 UTC
I can see the same behaviour using nouveau driver.. I can set panning to 3000x3000 but then I cannot move screen via mouse border crossing .. is possibility to move to hidden screen areas via mouse movement the fix you want to have here?

Comment 16 Tomas Pelka 2011-06-15 19:15:38 UTC
Dear Felix,

would you mind providing requested info (see #c13).

Thank you
Tom

Comment 17 Felix Kuehling 2011-06-15 21:58:05 UTC
(In reply to comment #13)
> I can see the same behaviour using nouveau driver.. I can set panning to
> 3000x3000 but then I cannot move screen via mouse border crossing .. is
> possibility to move to hidden screen areas via mouse movement the fix you want
> to have here?

Yes, that's what I had in mind.

Comment 19 Ganapathi Kamath 2011-06-25 23:53:27 UTC
Also present on fedora-15/x86_64/radeon HD3410/2.6.38.8-32.fc15.x86_64
xorg-x11-server-Xorg-1.10.2-1.fc15.x86_64
Cannot make local desktop pan a larger virtual screen.
xrandr --fb 1600x1280 --output LVDS --mode 1280x800 --panning 1600x1280

Use Case: 
* enable vino
* remote-desktop 
* enable a framebuffer size larger than LVDS with panning, note that VNC client is able to see the whole desktop.

Attempts to move the mouse in the vnc client outside the constraints of the local mouse pointer, perhaps also cause the Xmouse pointer to malfunction. It become stuck and shakes rapidly in place.

Should this be a separate bug in product line fedora ?

Comment 20 Ganapathi Kamath 2011-06-26 00:36:34 UTC
Bug 710191 is already filed for Fedora 15

Comment 21 Ganapathi Kamath 2011-06-26 21:59:54 UTC
Created attachment 510001 [details]
710191 (RandR 1.3 panning doesn't work on Fedora)

Comment 22 Ganapathi Kamath 2011-06-28 13:22:39 UTC
(In reply to comment #13)
> I can see the same behaviour using nouveau driver.. I can set panning to
> 3000x3000 but then I cannot move screen via mouse border crossing .. is
> possibility to move to hidden screen areas via mouse movement the fix you want
> to have here?

The panning area becomes the X-screen area. The panning area is usually larger than the CRTC area. Regions outside CRTC area but inside the panning area should not be considered hidden, as they can be reached by panning. Yes, it should be possible to reach those screen areas by CRTC-area border crossing. The mouse should be constrained to the whole panning-area, and not just the part originally visible as the CRTC area.

The mouse constraining feature is intended to keep the mouse inside only accessible areas, which includes area which can be panned to, and prevent the mouse from dragging windows to inaccessible regions.

According to me, the bug is that the mouse pointer constraints are using the CRTC boundaries and not the panning area boundaries.  
The mouse pointer should be prevented from border crossing the the panning area boundaries into areas might be inaccessible.

The fix to this issue does not come in conflict with the boundary-check-fix to keep the mouse away from inaccessible areas. Its just a matter of checking against the right boundary.

Comment 24 Adam Jackson 2011-08-15 16:32:00 UTC
3556059 build (RHEL-6.2-xorg-rebase, /cvs/dist:rpms/xorg-x11-server/RHEL-6:xorg-x11-server-1_10_3-5_el6) completed successfully

MODIFIED

Comment 26 hoolabaloooo 2011-08-26 19:54:49 UTC
confirmed also on FC15, intel gma, 1.10.3-1

boy this bug is _really_ annoying.

needed this both on the netbook and at work (need a "big display" emulation badly). therefore priority doesn't seem low to me personally


thanks

Comment 30 Dave Airlie 2011-11-11 14:45:18 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Panning was broken in RHEL 6.1.

Users could no longer configure panning modes on the X server using randr.

Patch was taking from upstream to fix.

Panning works for users.

Comment 31 errata-xmlrpc 2011-12-06 14:38:29 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2011-1602.html


Note You need to log in before you can comment on or make changes to this bug.