Bug 65526 - XFree86 freaks out with a ROM mapped at memory top
XFree86 freaks out with a ROM mapped at memory top
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.3
i386 Linux
low Severity high
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-26 20:28 EDT by Alan Cox
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-20 08:43:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
XFree86 log spew (5.22 KB, text/plain)
2002-05-27 11:53 EDT, Alan Cox
no flags Details

  None (edit)
Description Alan Cox 2002-05-26 20:28:00 EDT
On one of my boxes the second head is a 3DFx Voodoo card. The BIOS has an
unusual mapping strategy for PCI space which results in the 3DFx Expansion ROM
being mapped at 0xFFFF0000 for 64K. This fits but XFree86 complains about it and
refuses to initialize the BIOS mappings.

(EE) TDFX(0): Cannot read V_BIOS

It also moans about I/O port mapping errors reporting
(WW) ***INVALID IO ALLOCATION*** b: 0xffffff00 e: 0xffffffff correcting

I've no idea where the I/O allocation error is coming from. I'd be interested to
know if the V_BIOS one looks like XFree86 does something daft or if I should go
looking to see if that is a kernel bug
Comment 1 Mike A. Harris 2002-05-27 10:26:59 EDT
3Dfx cards can only be used as primary heads currently.  Some limitation
in the driver which nobody bothered to implement properly.  I recall
David Dawes commenting about it before.

If you change the BIOS to use the other card as secondary, it should work
ok though.  Unless of course both are 3Dfx cards.  ;o)
Comment 2 Mike A. Harris 2002-05-27 10:29:24 EDT
I hit send too soon...  duh

I'm going to ask upstream for information as to why nobody ever changed this,
and try to find out what the problem is.

Comment 3 Alan Cox 2002-05-27 10:42:24 EDT
It worked for me in 4.1 but not 4.0 on a different set up - Trident Cyberblade
secondary, 3Dfx Voodoo 4500 primary. Of course that may have been luck.

I'll build a test suite for the mmap cases and see if its the kernel anyway
Comment 4 Mike A. Harris 2002-05-27 11:29:57 EDT
With the 3Dfx primary there, it should work.  I haven't heard of reports of
dualhead with 3Dfx as primary failing, except if both heads are 3Dfx, in
which case it might cause problems like reported in some of the emails
I forwarded to you earlier.
Comment 5 Alan Cox 2002-05-27 11:53:58 EDT
Created attachment 58684 [details]
XFree86 log spew
Comment 6 Mike A. Harris 2002-05-28 02:23:55 EDT
Actually, can you attach the full XFree86.0.log file from startup through
to the end.  The info I wanted to look over is cut off.
Comment 7 Mike A. Harris 2002-12-15 04:46:45 EST
Defering bug for poking at later on.
Comment 8 Mike A. Harris 2005-04-20 08:43:18 EDT
Going to assume this one is no longer a problem in FC3/FC4 and close
CURRENTRELEASE, however if it still is a problem, someone should file
a bug report in X.Org bugzilla, so it's tracked in the community
tracker...

Setting status to "CURRENTRELEASE"

Note You need to log in before you can comment on or make changes to this bug.