Bug 655282 - Package spacewalk-utils has dependancies on Oracle
Summary: Package spacewalk-utils has dependancies on Oracle
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Spacewalk
Classification: Community
Component: Server
Version: 1.2
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: ---
Assignee: Michael Mráka
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard:
Depends On:
Blocks: space16
TreeView+ depends on / blocked
 
Reported: 2010-11-20 06:37 UTC by Colin Coe
Modified: 2011-07-25 18:17 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-07-25 18:17:54 UTC


Attachments (Terms of Use)

Description Colin Coe 2010-11-20 06:37:26 UTC
Description of problem:
Package spacewalk-utils has dependancies on Oracle

Version-Release number of selected component (if applicable):
Spacewalk 1.2

How reproducible:
Postgresql Spacewalk install:
yum install -y spacewalk-utils

Steps to Reproduce:
1.yum install -y spacewalk-utils
  
Actual results:
yum install spacewalk-utils
Loaded plugins: presto, refresh-packagekit
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package spacewalk-utils.noarch 0:1.3.1-1.fc13 set to be installed
--> Processing Dependency: /usr/bin/sqlplus for package: spacewalk-utils-1.3.1-1.fc13.noarch
--> Processing Dependency: perl(Term::ReadKey) for package: spacewalk-utils-1.3.1-1.fc13.noarch
--> Running transaction check
---> Package oracle-lib-compat.x86_64 0:10.2.0.25-1.fc13 set to be installed
--> Processing Dependency: oracle-instantclient-basic = 10.2.0.4 for package: oracle-lib-compat-10.2.0.25-1.fc13.x86_64
--> Processing Dependency: oracle-instantclient-sqlplus = 10.2.0.4 for package: oracle-lib-compat-10.2.0.25-1.fc13.x86_64
--> Processing Dependency: libstdc++.so.5()(64bit) for package: oracle-lib-compat-10.2.0.25-1.fc13.x86_64
---> Package perl-TermReadKey.x86_64 0:2.30-9.fc13 set to be installed
--> Running transaction check
---> Package compat-libstdc++-33.x86_64 0:3.2.3-68 set to be installed
---> Package oracle-lib-compat.x86_64 0:10.2.0.25-1.fc13 set to be installed
--> Processing Dependency: oracle-instantclient-basic = 10.2.0.4 for package: oracle-lib-compat-10.2.0.25-1.fc13.x86_64
--> Processing Dependency: oracle-instantclient-sqlplus = 10.2.0.4 for package: oracle-lib-compat-10.2.0.25-1.fc13.x86_64
--> Finished Dependency Resolution
Error: Package: oracle-lib-compat-10.2.0.25-1.fc13.x86_64 (spacewalk)
           Requires: oracle-instantclient-sqlplus = 10.2.0.4
Error: Package: oracle-lib-compat-10.2.0.25-1.fc13.x86_64 (spacewalk)
           Requires: oracle-instantclient-basic = 10.2.0.4
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
[root@sw-pg log]#

Expected results:
spacewalk-utils should install qithout requiring Oracle

Additional info:

Comment 1 Miroslav Suchý 2011-04-11 07:32:33 UTC
We did not have time for this one during Spacewalk 1.4 time frame. Mass moving to Spacewalk 1.5.

Comment 2 Miroslav Suchý 2011-04-11 07:36:49 UTC
We did not have time for this one during Spacewalk 1.4 time frame. Mass moving to Spacewalk 1.5.

Comment 3 Jan Pazdziora 2011-07-20 11:50:32 UTC
Aligning under space16.

Comment 4 Jan Pazdziora 2011-07-25 18:17:54 UTC
The dependency on /usr/bin/sqlplus was removed by Michael in commit f88ed33e217158ab4f5d778129f242077681ddf2, spacewalk-utils-1.4.2.

Marking as resolved, please reopen if you disagree.


Note You need to log in before you can comment on or make changes to this bug.