Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 655309 - Wrong permissions on /dev/dri
Summary: Wrong permissions on /dev/dri
Keywords:
Status: CLOSED DUPLICATE of bug 626559
Alias: None
Product: Fedora
Classification: Fedora
Component: mesa
Version: rawhide
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: ---
Assignee: Adam Jackson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-11-20 12:13 UTC by Peter Hjalmarsson
Modified: 2010-11-22 10:18 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-11-22 10:18:27 UTC
Type: ---


Attachments (Terms of Use)

Description Peter Hjalmarsson 2010-11-20 12:13:09 UTC
Description of problem:
Since I upgraded to rawhide from Fedora14 I have had the following problem:

[xake@ferra ~]$ ls -ld /dev/dri
drwxr-x---. 2 root root 80 20 nov  2010 /dev/dri

This prevents me from using anything DDRI on my ATI Radeon x1600 system, since nothing run as non-root can access this.

Version-Release number of selected component (if applicable):
$ yum list installed | grep mesa
mesa-dri-drivers.i686                    7.10-0.11.fc15                 @rawhide
mesa-dri-drivers.x86_64                  7.10-0.11.fc15                 @rawhide
I guess this is the components that are interesting since they hold the drivers

How reproducible:
Have tried two upgrades on two computers (Intel i945, ATI x1600), and both had this problem.

Steps to Reproduce:
1. Install Fedora 14
2. Enable Rawhide repos
3. "yum upgrade" (or let package kit handle)
4. reboot
  
Actual results:
$ glxinfo | grep renderer
OpenGL renderer string: Gallium 0.4 on llvmpipe


Expected results:
$ glxinfo | grep renderer
OpenGL renderer string: Gallium 0.4 on ATI RV530


Additional info:
If I "chmod a+rX /dev/dri" everything starts to work until next reboot.

Comment 1 Yanko Kaneti 2010-11-20 18:25:38 UTC
See bug 626559.
Please make sure your initramfs was generated by dracut-008-0.10.gitb2415f4.fc15 or later.

Comment 2 Peter Hjalmarsson 2010-11-22 09:58:57 UTC
Yep, helped. Thanks.

Comment 3 Yanko Kaneti 2010-11-22 10:18:27 UTC

*** This bug has been marked as a duplicate of bug 626559 ***


Note You need to log in before you can comment on or make changes to this bug.