Bug 655329 - Option "MaximumXPosition" has no no effect
Summary: Option "MaximumXPosition" has no no effect
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-fpit
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Peter Hutterer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-11-20 14:10 UTC by jkltechinc
Modified: 2012-03-02 01:47 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-03-02 01:47:18 UTC
Type: ---


Attachments (Terms of Use)

Description jkltechinc 2010-11-20 14:10:07 UTC
Description of problem:
Fpit driver works fine using the xorg.conf I've always used since Fedora 8, except for the X-axis calibration.  Changing the numbers make no difference.

Version-Release number of selected component (if applicable):


How reproducible: Every time


Steps to Reproduce:
1. Configure set serial
2. Create Xorg.conf
3. Try changing X-axis calibration values
  
Actual results:
X-Axis calibration never changes.  My cursor goes all the way to the right of the screen when the pen is only half way.


Expected results:
Calibration values should show results.


Additional info: Similar problem was encountered in Ubuntu.
https://bugs.edge.launchpad.net/null/+bug/576677
http://ubuntuforums.org/showthread.php?t=1466002

Comment 1 Adam Jackson 2011-11-09 21:40:29 UTC
Wow, an fpit user.  The driver's unmaintained upstream now though.

Comment 2 Peter Hutterer 2012-03-02 01:47:18 UTC
Sorry, we can't fix this issue. The driver was unmaintained and untested upstream for several releases and does not ship in Fedora anymore.

If you are willing to take over input driver maintainership for the upstream driver please contact me directly and we'll sort something out. At this point, the best option I can recommend though is to write a kernel driver and use the evdev driver.


Note You need to log in before you can comment on or make changes to this bug.