Bug 655371 - wireless network cam't be enabled with networkmanager after upgrade from fedora 13
Summary: wireless network cam't be enabled with networkmanager after upgrade from fedo...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: NetworkManager
Version: 14
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: ---
Assignee: Dan Williams
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-11-20 18:04 UTC by pasqual milvaques
Modified: 2010-11-30 09:57 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-11-30 09:57:35 UTC
Type: ---


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Linux Kernel 16570 0 None None None Never

Description pasqual milvaques 2010-11-20 18:04:11 UTC
Description of problem:
I used the networkmanager applet to enable/disable wifi. afeter upgrading the swicth to do it in the networkmanager applet id not working anymore. I have rechecked all the configuration and I don't see anything incorrect

I have checked that the wifi card is working doing:
ifconfig wlan0 up (to enable the card)
iwlist wlan0 scan (to search networks, it found networks)

I have taken a look with the cli version and this are the results:

[root@xxxx etc]# nmcli -p nm
======================================================================================
                                NetworkManager status
======================================================================================
RUNNING         STATE           WIFI-HARDWARE   WIFI       WWAN-HARDWARE   WWAN      
--------------------------------------------------------------------------------------
running         connected       enabled         disabled   enabled         enabled   
[root@xxxx etc]# 

if I try do enable it there is no change:
[root@xxxx etc]# nmcli -p nm wifi on;nmcli -p nm wifi
================
  WiFi enabled
================
WIFI      
----------------
disabled  
[root@xxxx etc]# 

nm-tool says that the wifi device is unavaliable:
[root@xxxx ~]$ nm-tool 

NetworkManager Tool

State: connected

- Device: eth0  [System eth0] --------------------------------------------------
  Type:              Wired
  Driver:            r8169
  State:             connected
  Default:           yes
 .................................

- Device: wlan0 ----------------------------------------------------------------
  Type:              802.11 WiFi
  Driver:            iwlagn
  State:             unavailable
  Default:           no
  HW Address:        xx:xx:xx:xx:xx:xx

  Capabilities:

  Wireless Properties
    WEP Encryption:  yes
    WPA Encryption:  yes
    WPA2 Encryption: yes

  Wireless Access Points 


[root@xxxx ~]$ 


Version-Release number of selected component (if applicable):
NetworkManager-vpnc-0.8.1-1.fc14.x86_64
NetworkManager-pptp-0.8.1-1.fc14.x86_64
NetworkManager-glib-0.8.1-10.git20100831.fc14.x86_64
NetworkManager-0.8.1-10.git20100831.fc14.x86_64
NetworkManager-gnome-0.8.1-10.git20100831.fc14.x86_64
NetworkManager-openconnect-0.8.1-1.fc14.x86_64
NetworkManager-openvpn-0.8.1-1.fc14.x86_64

How reproducible:
using the enable wireless switch of the networmanager applet or the nmcli command

Steps to Reproduce:
1. open a shell and check that the card works doing a ifconfig wlan0 up;iwlist wlan0 scan
2.use nm-tool to see the status of the card
3.try to change the status of the card with a nmcli -p nm wifi on and verift with a nmcli -p nm or with nm-tool that the card remains unavaliable
  
Actual results:
wireless connectivity doesn't work with networkmanager

Expected results:
the wifi card enabled and using network manager to connect to a network

Additional info:
card is a intel 5100, was working perfectly in fedora 13
[root@xxxx etc]# lspci | grep -i wifi
03:00.0 Network controller: Intel Corporation WiFi Link 5100
[root@xxxx etc]#

Comment 1 pasqual milvaques 2010-11-21 14:08:03 UTC
smolt profile of the machine:
http://www.smolts.org/client/show/pub_c7e40328-c264-4299-8077-1b46ddb74283

perhaps there is a kernel level problem around this. I have tried to enable/disable the device with rfkill and there is some proble, it blobls the incorrect interface:
[pasqual@yaddith ~]$ rfkill list
0: acer-wireless: Wireless LAN
	Soft blocked: yes
	Hard blocked: no
1: phy0: Wireless LAN
	Soft blocked: no
	Hard blocked: no
[pasqual@yaddith ~]$ rfkill block 0
[pasqual@yaddith ~]$ rfkill list
0: acer-wireless: Wireless LAN
	Soft blocked: yes
	Hard blocked: no
1: phy0: Wireless LAN
	Soft blocked: no
	Hard blocked: yes
[pasqual@yaddith ~]$ 

in dmesg are appering kernel crashes:
[25897.819635] ------------[ cut here ]------------
[25897.819669] WARNING: at net/wireless/core.c:633 wdev_cleanup_work+0x52/0xbd [cfg80211]()
[25897.819675] Hardware name: EASYNOTE TN65  
[25897.819680] Modules linked in: fuse sunrpc cpufreq_ondemand acpi_cpufreq freq_table mperf ip6t_REJECT nf_conntrack_ipv6 ip6table_filter ip6_tables ipv6 uinput arc4 ecb snd_hda_codec_atihdmi snd_hda_codec_realtek snd_hda_intel iwlagn snd_hda_codec snd_hwdep snd_seq snd_seq_device iwlcore mac80211 snd_pcm cfg80211 snd_timer uvcvideo snd acer_wmi rfkill videodev v4l1_compat r8169 iTCO_wdt soundcore snd_page_alloc serio_raw v4l2_compat_ioctl32 mii iTCO_vendor_support i2c_i801 wmi joydev microcode usb_storage video output radeon ttm drm_kms_helper drm i2c_algo_bit i2c_core [last unloaded: scsi_wait_scan]
[25897.819787] Pid: 735, comm: cfg80211 Not tainted 2.6.35.6-48.fc14.x86_64 #1
[25897.819792] Call Trace:
[25897.819808]  [<ffffffff8104d7c1>] warn_slowpath_common+0x85/0x9d
[25897.819820]  [<ffffffff8104d7f3>] warn_slowpath_null+0x1a/0x1c
[25897.819836]  [<ffffffffa01ee4c7>] wdev_cleanup_work+0x52/0xbd [cfg80211]
[25897.819847]  [<ffffffff81062571>] worker_thread+0x1c5/0x251
[25897.819863]  [<ffffffffa01ee475>] ? wdev_cleanup_work+0x0/0xbd [cfg80211]
[25897.819873]  [<ffffffff810663c3>] ? autoremove_wake_function+0x0/0x39
[25897.819885]  [<ffffffff8146912f>] ? _raw_spin_unlock_irqrestore+0x17/0x19
[25897.819893]  [<ffffffff810623ac>] ? worker_thread+0x0/0x251
[25897.819901]  [<ffffffff81065f29>] kthread+0x7f/0x87
[25897.819911]  [<ffffffff8100aae4>] kernel_thread_helper+0x4/0x10
[25897.819919]  [<ffffffff81065eaa>] ? kthread+0x0/0x87
[25897.819927]  [<ffffffff8100aae0>] ? kernel_thread_helper+0x0/0x10
[25897.819933] ---[ end trace f327e896a848008a ]---

I have uploaded a kerneloops report

Comment 2 pasqual milvaques 2010-11-21 14:29:45 UTC
problem can be relat with bug 593566. in it the card giving problems is of the same model and the kernel crash is similar

Comment 3 Jirka Klimes 2010-11-25 14:57:52 UTC
(In reply to comment #1)
> [pasqual@yaddith ~]$ rfkill list
> 0: acer-wireless: Wireless LAN
>  Soft blocked: yes
>  Hard blocked: no
> 1: phy0: Wireless LAN
>  Soft blocked: no
>  Hard blocked: no
> [pasqual@yaddith ~]$ rfkill block 0
> [pasqual@yaddith ~]$ rfkill list
> 0: acer-wireless: Wireless LAN
>  Soft blocked: yes
>  Hard blocked: no
> 1: phy0: Wireless LAN
>  Soft blocked: no
>  Hard blocked: yes
> [pasqual@yaddith ~]$ 
> 

I would say the actual issue here is the ACER platform driver that blocks the device.
Try blacklist acer-wmi driver.

More info here:
https://bugzilla.kernel.org/show_bug.cgi?id=16570

Comment 4 pasqual milvaques 2010-11-25 16:06:09 UTC
correct!!

the problem was that, as soon as the module is unloaded all works perfectly

thanks!!

Comment 5 Jirka Klimes 2010-11-30 09:57:35 UTC
Closing per comment #4.


Note You need to log in before you can comment on or make changes to this bug.