Bug 655426 - anaconda asks for a disk information I have no way to provide
Summary: anaconda asks for a disk information I have no way to provide
Keywords:
Status: CLOSED DUPLICATE of bug 649865
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 14
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-11-20 22:03 UTC by Michal Jaegermann
Modified: 2010-11-22 16:41 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-11-22 13:31:25 UTC


Attachments (Terms of Use)

Description Michal Jaegermann 2010-11-20 22:03:44 UTC
Description of problem:

On a system with three SATA disks, two of which happens to be the same model, I am running an upgrade of an F13 installation which is using file systems which happen to reside somewhere on those two "the same" disks.

After I already picked up from a menu what I want to upgrade anaconda asks me to  choose disks I desire to be used.  The answer is simple - I want those disks on which an installation to be upgraded happens to reside.  Instead I am presented with a list where are given disks models, capacity and pci identifiers.  The trouble is that those identfiers look like pci-0000:00:08-scsi-0:0:0:0 and
pci-0000:00:08-scsi-1:0:0:0 and nothing on a system, AFAICT, exposes an information of that sort and it is not even clear if this does not depend on a PCI scan order and it would not move across different boots.  I could have most likely picked up all disks but anaconda insists that I will tell which will be a boot device so I am back into a guessing game with very unclear chances to win. What all of this is about?

A disk serial number could have been recorded and provided if really necessary but anaconda should already know anyway with what is really dealing (and quite possibly even does).

What one should answer in a case of a new installation with many disks of the same model I am not that sure.

Version-Release number of selected component (if applicable):
anaconda version 14.22 as used in Fedora 14 release

Comment 1 Chris Lumens 2010-11-22 13:31:25 UTC
This screen should simply never be shown on upgrades.

*** This bug has been marked as a duplicate of bug 649865 ***

Comment 2 Michal Jaegermann 2010-11-22 16:18:36 UTC
(In reply to comment #1)
> This screen should simply never be shown on upgrades.

Indeed.  But what about a case, like I wrote, "of a new installation with many disks of the same model"?  I do not think that this would be less baffling.

Comment 3 Chris Lumens 2010-11-22 16:41:41 UTC
I suppose we could add an extra column into the drop down, perhaps the device name.


Note You need to log in before you can comment on or make changes to this bug.