Bug 65543 - X11 forwarding broken on IPv4 + IPv6 machines
X11 forwarding broken on IPv4 + IPv6 machines
Status: CLOSED DUPLICATE of bug 60982
Product: Red Hat Linux
Classification: Retired
Component: openssh (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tomas Mraz
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-27 06:28 EDT by Per Steinar Iversen
Modified: 2007-04-18 12:42 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-03 08:03:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Per Steinar Iversen 2002-05-27 06:28:28 EDT
Description of Problem:

X11 forwarding does not work on IPv4 + IPv6 machines. This because the X11
forwarder listen to ::1 while ssh tries to connect to 127.0.0.1 in order to
reach the forwarder.

There is a workaround, add this to /etc/ssh/sshd_config :

X11UseLocalhost no

After restarting X11 forwarding works as expected


Version-Release number of selected component (if applicable): openssh-3.1p1-3


How Reproducible: Always


Steps to Reproduce:

1. Login with ssh on a IPv4 + IPv6 machine, it does not matter if this is done
over IPv4 or IPv6.
2. Try to start any X11 application, for example xterm
3. The application fails to start

Actual Results:

X11 forwarding does not work.


Expected Results:

That X11 forwarding works.

Additional Information:

A workaround is available, but it would be better to fix the IPv4 loopback vs.
IPv6 loopback confusion.
Comment 1 Tomas Mraz 2005-02-03 08:03:31 EST

*** This bug has been marked as a duplicate of 60982 ***

Note You need to log in before you can comment on or make changes to this bug.