Bug 655435 - No sound on Macbook pro 7,1 with fedora 14
Summary: No sound on Macbook pro 7,1 with fedora 14
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: alsa-lib
Version: 14
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: ---
Assignee: Jaroslav Kysela
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-11-20 22:59 UTC by rgeorge280
Modified: 2012-08-16 18:29 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-08-16 18:29:32 UTC


Attachments (Terms of Use)

Description rgeorge280 2010-11-20 22:59:43 UTC
Description of problem:
There is no sound for anything in Fedora 14 on the Macbook Pro 7,1.  I do not know if this is actually an Alsa problem, but it was a required field, so I put it down as a section that dealt with linux sound.

Version-Release number of selected component (if applicable):


How reproducible:
just fresh install fedora 14 onto a macbook pro 7,1

Steps to Reproduce:
1. Using Fedora 14 on a Macbook Pro 7,1, simply try to play anything with sound (such as a video or music file)
2.
3.
  
Actual results:
There is no sound output to the internal speakers, nor the headphones when they are plugged in.

Expected results:
There should be sound playing.

Additional info:  I have followed "Bernardbizda"'s instructions on this forum post here: http://forums.fedoraforum.org/showthread.php?t=250510.  In his instructions, one of the lines he says to write to the file is "options snd-hda-intel model=mbp3".  I have tried leaving that line as is, AND I have tried it as "model=mbp55" because that is the line that worked in the instructions for Ubuntu here: https://help.ubuntu.com/community/MacBookPro7-1/Maverick#Sound

Neither of these worked.

Comment 1 rgeorge280 2010-11-21 07:27:59 UTC
Okay, I just restarted again, and for the hell of it I tried switching the sound card and unmuting/raising the volume of the proper channels in alsamixer again.  Something that I have to do every time I restart to test the audio.  Anyway, for some reason this time it worked.

It has to be because of the instructions from the forum post which I linked to, but I DID restart after the finishing with the instructions before testing out the sound so I don't know why it should need to restart twice.  But anyway, currently my /etc/modprobe.d/sound.conf file only has the following line: "options snd_hda_intel model=mbp55"

That's the only change that I did to get the sound working, so I don't know why it took this long to work.  But anyway, sounds still doesn't work by default on the macbook pro 7,1 with Fedora 14.

Comment 2 Fedora End Of Life 2012-08-16 18:29:35 UTC
This message is a notice that Fedora 14 is now at end of life. Fedora 
has stopped maintaining and issuing updates for Fedora 14. It is 
Fedora's policy to close all bug reports from releases that are no 
longer maintained.  At this time, all open bugs with a Fedora 'version'
of '14' have been closed as WONTFIX.

(Please note: Our normal process is to give advanced warning of this 
occurring, but we forgot to do that. A thousand apologies.)

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, feel free to reopen 
this bug and simply change the 'version' to a later Fedora version.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we were unable to fix it before Fedora 14 reached end of life. If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora, you are encouraged to click on 
"Clone This Bug" (top right of this page) and open it against that 
version of Fedora.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping


Note You need to log in before you can comment on or make changes to this bug.