Bug 65545 - clnt_call() returns Failure in multithread environment on RH7.2
clnt_call() returns Failure in multithread environment on RH7.2
Status: CLOSED DUPLICATE of bug 65544
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.2
i586 Linux
high Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-27 07:15 EDT by Konda Reddy
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-27 07:15:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
new.tar file has the sample to reproduce the Bug. (110.00 KB, application/octet-stream)
2002-05-27 07:19 EDT, Konda Reddy
no flags Details

  None (edit)
Description Konda Reddy 2002-05-27 07:15:41 EDT
Description of Problem:
I have a multi-threaded client, in which I create
CLIENT handle in the first thread, and then use
clnt_call in other child-threads to access server.
If the clnt_create() and clnt_call() are invoked in the same thread then 
clnt_call() returns success. 
On Linux RH7.1 there is no problem. but it's giving problem on RH7.2 (2.4.7-10 
#1 Thu Sep 6 17:21:28 EDT 2001 i586). 

Version-Release number of selected component (if applicable):


How Reproducible:
Call clnt_create() in one thread and get the CLIENT pointer then call clnt_call
() in another thread by passing the same CLIENT pointer. It returns Failure.

I am attaching a file new.tar this contains
compile - to compile the sameple.
after compilation just run
1. dateproc &
2. rdate "hostname"  (hostname must be the host for the dateproc server)

you will see the problem. saying that clnt_call failed.

Steps to Reproduce:
1. 
2. 
3. 

Actual Results:
clnt_call() returns FAILURE.

Expected Results:
clnt_call() should return SUCCESS.

Additional Information:
Comment 1 Arjan van de Ven 2002-05-27 07:17:31 EDT

*** This bug has been marked as a duplicate of 65544 ***
Comment 2 Konda Reddy 2002-05-27 07:19:35 EDT
Created attachment 58665 [details]
new.tar file has the sample to reproduce the Bug.

Note You need to log in before you can comment on or make changes to this bug.