Bug 65548 - dos2unix fails when output is on other file system
dos2unix fails when output is on other file system
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: dos2unix (Show other bugs)
7.3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-27 09:41 EDT by Need Real Name
Modified: 2007-04-18 12:42 EDT (History)
0 users

See Also:
Fixed In Version: 3.1-21
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-20 11:31:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-05-27 09:41:55 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)

Description of problem:
dos2unix filas when cuurent directory is on a different file system than the 
output file.  If output and input file is the same file, the input file is 
furthermore deleted.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. cd /home/user
2. touch /tmp/foo
3. dos2unix /tmp/foo
	

Actual Results:  If /home/usr and /tmp are on different file systems, /tmp/foo 
is permanently deleted.

Expected Results:  Left for the reader...

Additional info:

The cause is trivial, input file is `unlink'ed, output generated as a temporary 
file in the current directory and the tried `rename'd to the output location.  
`rename' obviously fails, as it cannot move between file systems.
Comment 1 Miloslav Trmač 2004-10-20 11:31:16 EDT
Fixed in dos2unix-3.1-21. Thanks for your report.
Comment 2 Tim Powers 2005-05-19 20:35:31 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2005-195.html

Note You need to log in before you can comment on or make changes to this bug.