Bug 655505 - 'yum update' Dependency Resolution
'yum update' Dependency Resolution
Status: CLOSED DUPLICATE of bug 654638
Product: Fedora
Classification: Fedora
Component: openssl (Show other bugs)
14
Unspecified Unspecified
low Severity medium
: ---
: ---
Assigned To: Tomas Mraz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-11-21 08:04 EST by NM
Modified: 2010-11-21 14:46 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-21 14:05:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description NM 2010-11-21 08:04:20 EST
[root@localhost ~]#  yum update
Loaded plugins: auto-update-debuginfo, langpacks, presto, protectbase, refresh-packagekit
Adding en_US to language list
Found 3 installed debuginfo package(s)
Enabling fedora-debuginfo: Fedora 14 - x86_64 - Debug
Enabling rpmfusion-nonfree-debuginfo: RPM Fusion for Fedora 14 - Nonfree - Debug
Enabling updates-debuginfo: Fedora 14 - x86_64 - Updates - Debug
Enabling rpmfusion-free-updates-debuginfo: RPM Fusion for Fedora 14 - Free - Updates Debug
Enabling rpmfusion-free-debuginfo: RPM Fusion for Fedora 14 - Free - Debug
Enabling rpmfusion-nonfree-updates-debuginfo: RPM Fusion for Fedora 14 - Nonfree - Updates Debug
rpmfusion-free-updates-debuginfo                                                                                                                                                                                      | 2.7 kB     00:00     
rpmfusion-nonfree-updates-debuginfo                                                                                                                                                                                   | 2.7 kB     00:00     
updates-debuginfo/metalink                                                                                                                                                                                            |  13 kB     00:00     
updates-debuginfo                                                                                                                                                                                                     | 3.1 kB     00:00     
updates-debuginfo/primary_db                                                                                                                                                                                          | 157 kB     00:00     
0 packages excluded due to repository protections
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package glibc-debuginfo.x86_64 0:2.12.90-19 set to be updated
---> Package openssl.x86_64 0:1.0.0b-1.fc14 set to be updated
---> Package openssl-devel.x86_64 0:1.0.0b-1.fc14 set to be updated
updates-debuginfo/filelists_db                                                                                                                                                                                        | 2.1 MB     00:04     
--> Processing Dependency: /lib64/.libcrypto.so.1.0.0a.hmac for package: 1:libguestfs-1.6.0-1.fc14.1.x86_64
--> Processing Dependency: /usr/lib64/.libssl.so.1.0.0a.hmac for package: 1:libguestfs-1.6.0-1.fc14.1.x86_64
--> Finished Dependency Resolution
Error: Package: 1:libguestfs-1.6.0-1.fc14.1.x86_64 (@updates)
           Requires: /usr/lib64/.libssl.so.1.0.0a.hmac
           Removing: openssl-1.0.0a-2.fc14.x86_64 (@anaconda-InstallationRepo-201010211827.x86_64)
               Not found
           Updated By: openssl-1.0.0b-1.fc14.x86_64 (updates)
               Not found
Error: Package: 1:libguestfs-1.6.0-1.fc14.1.x86_64 (@updates)
           Requires: /lib64/.libcrypto.so.1.0.0a.hmac
           Removing: openssl-1.0.0a-2.fc14.x86_64 (@anaconda-InstallationRepo-201010211827.x86_64)
               Not found
           Updated By: openssl-1.0.0b-1.fc14.x86_64 (updates)
               Not found
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
Comment 1 Magnus Glantz 2010-11-21 14:04:37 EST
Duplicate of BZ #654638
Comment 2 Magnus Glantz 2010-11-21 14:05:00 EST

*** This bug has been marked as a duplicate of bug 654638 ***
Comment 3 Richard W.M. Jones 2010-11-21 14:46:06 EST
Please try the libguestfs package from updates-testing.  It
no longer depends on these two files.

https://admin.fedoraproject.org/updates/libguestfs-1.6.2-1.fc14.4

Note You need to log in before you can comment on or make changes to this bug.