Bug 65551 - Unassigned RAID (type 0xfd) partitions cause traceback
Unassigned RAID (type 0xfd) partitions cause traceback
Status: CLOSED DUPLICATE of bug 64734
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.3
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-27 10:47 EDT by Heinz Deinhart
Modified: 2007-04-18 12:42 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-06-04 11:28:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda generated dump (64.56 KB, text/plain)
2002-05-27 10:48 EDT, Heinz Deinhart
no flags Details

  None (edit)
Description Heinz Deinhart 2002-05-27 10:47:55 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.79 [en] (X11; U; Linux 2.4.18-3 i586)

Description of problem:
after selecting packages the installer dies with an exception (see dump)

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. take new compaq DL380
2. insert 2 9G SCSI drives and one 18G and one IDE CDROM
3. try to make install with root on raid partition

more details in anaconda dump
	

Additional info:
Comment 1 Heinz Deinhart 2002-05-27 10:48:58 EDT
Created attachment 58666 [details]
anaconda generated dump
Comment 2 Heinz Deinhart 2002-05-27 12:08:42 EDT
Found out more details:

This happens when you assign some raid partitions (type 0xfd) with fdisk and
then
do not assign all of them in the installer. Those unassigned will not be
formatted, and then the installer crashes when trying to start them up.

The reason i did not assign all of them is: it does not seem possible
to create a RAID 1 on top of a RAID 0 device.
Comment 3 Michael Fulbright 2002-06-04 11:28:43 EDT
Assigning to an engineer.
Comment 4 Jeremy Katz 2002-06-04 11:52:33 EDT
Can you try using the update disk available at
http://people.redhat.com/~katzj/73raid.img?  If you put that on a separate
floppy and boot with 'linux updates', inserting the disk when prompted, it
should fix the problem.

*** This bug has been marked as a duplicate of 64734 ***
Comment 5 Michael Fulbright 2002-12-20 12:38:25 EST
Time tracking values updated

Note You need to log in before you can comment on or make changes to this bug.