Bug 655553 - Handwrite input less than perfect on screens with low horizontal resolution
Summary: Handwrite input less than perfect on screens with low horizontal resolution
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: ibus-handwrite
Version: 14
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: ---
Assignee: Peng Wu
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-11-21 16:25 UTC by DemetrisK
Modified: 2010-12-01 22:04 UTC (History)
5 users (show)

Fixed In Version: ibus-handwrite-2.1.1-1.fc13
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-12-01 21:54:25 UTC


Attachments (Terms of Use)
screenshot (50.68 KB, image/png)
2010-11-21 16:25 UTC, DemetrisK
no flags Details

Description DemetrisK 2010-11-21 16:25:06 UTC
Created attachment 461843 [details]
screenshot

Description of problem:
The input region of the ibus-handwrite (for Japanese and Chinese characters) appears cropped in the down side of the screen, especially on 16:9 netbook screens with 600 pixels of horizontal resolution (see attchmnt) which makes input difficult and choosing the proposed characters impossible. There should be a way to move the input window.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Peng Wu 2010-11-23 02:18:50 UTC
Actually you can move it by holding the right mouse key.

Comment 2 DemetrisK 2010-11-23 05:21:43 UTC
Oh, mea culpa then.
I can't check it right now, but even so, it's not intuitive. Since alt+drag can't be used, a small addition of a tooltip or a line of text in the About screen could be helpful. Except if I am missing something.

Comment 3 Peng Wu 2010-11-26 02:20:57 UTC
I will add a tooltip to ibus-handwrite, like:
"<b>Hint:</b>\n"
"Left mouse key to draw strokes.\n"
"Holding right mouse key to move the widget.\n"

Is this OK?

Comment 4 DemetrisK 2010-11-26 06:13:17 UTC
It seems reasonable enough for me. 
Thanks for taking care of the improvement request.

Comment 5 Fedora Update System 2010-11-29 01:36:57 UTC
ibus-handwrite-2.1.1-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/ibus-handwrite-2.1.1-1.fc14

Comment 6 Fedora Update System 2010-11-29 01:38:52 UTC
ibus-handwrite-2.1.1-1.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/ibus-handwrite-2.1.1-1.fc13

Comment 7 Fedora Update System 2010-11-29 21:36:01 UTC
ibus-handwrite-2.1.1-1.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update ibus-handwrite'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/ibus-handwrite-2.1.1-1.fc14

Comment 8 Fedora Update System 2010-12-01 21:54:21 UTC
ibus-handwrite-2.1.1-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2010-12-01 22:04:04 UTC
ibus-handwrite-2.1.1-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.