Bug 655558 - Missing .pm file
Summary: Missing .pm file
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: perl-Data-TreeDumper
Version: 14
Hardware: i686
OS: Linux
low
low
Target Milestone: ---
Assignee: Chris Weyl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-11-21 17:40 UTC by Douglas Furlong
Modified: 2011-03-07 13:16 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-03-07 13:16:11 UTC


Attachments (Terms of Use)

Description Douglas Furlong 2010-11-21 17:40:18 UTC
Description of problem:
When trying to run /usr/share/doc/perl-Data-TreeDumper-0.35/usage.pl it reports a file is missing.



Version-Release number of selected component (if applicable):
Name        : perl-Data-TreeDumper         Relocations: (not relocatable)
Version     : 0.35                              Vendor: Fedora Project
Release     : 7.fc14                        Build Date: Fri 30 Apr 2010 14:46:07 BST


How reproducible:
100%

Steps to Reproduce:
1. Attempt to run usage.pl
2.
3.
  
Actual results:
Error relating to missing OO.pm file

Expected results:
Not 100% sure, but I'd assume the .pl file would run showing an example display.

Additional info:
I think the issue is relating to the following in the usage.pl file.
Data::TreeDumper::OO

Comment 1 Marcela Mašláňová 2011-03-07 13:16:11 UTC
File usage.pl is stored in docs.
/usr/share/doc/perl-Data-TreeDumper-0.37/usage.pl

Fedora's Packaging Guidelines says that doc files are no executable and it should not have run time dependencies. Therefore we are not even trying mention all requires in spec-file. The package providing this file is not even in Fedora.


Note You need to log in before you can comment on or make changes to this bug.