Bug 655576 - [abrt] fedpkg-0.5.1.4-5.fc14: __init__.py:1210:gimmespec:FedpkgError: No spec file found.
Summary: [abrt] fedpkg-0.5.1.4-5.fc14: __init__.py:1210:gimmespec:FedpkgError: No spec...
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: fedora-packager
Version: 14
Hardware: x86_64
OS: Unspecified
low
medium
Target Milestone: ---
Assignee: David Cantrell
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:ca9f3706
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-11-21 19:38 UTC by Matthew Truch
Modified: 2013-01-10 06:21 UTC (History)
2 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2011-01-19 21:05:16 UTC


Attachments (Terms of Use)
File: backtrace (721 bytes, text/plain)
2010-11-21 19:38 UTC, Matthew Truch
no flags Details

Description Matthew Truch 2010-11-21 19:38:44 UTC
abrt version: 1.1.13
architecture: x86_64
component: fedora-packager
executable: /usr/bin/fedpkg
kernel: 2.6.35.6-48.fc14.x86_64
package: fedpkg-0.5.1.4-5.fc14
reason: __init__.py:1210:gimmespec:FedpkgError: No spec file found.
release: Fedora release 14 (Laughlin)
How to reproduce: Try to run fedpkg update.
time: 1290368167
uid: 500

backtrace
-----
__init__.py:1210:gimmespec:FedpkgError: No spec file found.

Traceback (most recent call last):
  File "/usr/bin/fedpkg", line 1086, in <module>
    args.command(args)
  File "/usr/bin/fedpkg", line 664, in update
    mymodule = pyfedpkg.PackageModule(args.path)
  File "/usr/lib/python2.7/site-packages/pyfedpkg/__init__.py", line 903, in __init__
    self.spec = self.gimmespec()
  File "/usr/lib/python2.7/site-packages/pyfedpkg/__init__.py", line 1210, in gimmespec
    raise FedpkgError('No spec file found.')
FedpkgError: No spec file found.

Local variables in innermost frame:
files: ['f12', 'f14', 'el4', 'f10', 'f13', 'master', 'el6', 'el5', 'f11']
self: <pyfedpkg.PackageModule instance at 0x1778e60>
f: 'f11'

Comment 1 Matthew Truch 2010-11-21 19:38:50 UTC
Created attachment 461861 [details]
File: backtrace

Comment 2 Jesse Keating 2010-11-22 19:53:36 UTC
what's in the current working directory that you ran "fedpkg update" in?  It sounds like there was no working files, no spec file or anything, for fedpkg to discover what package it's working on.

Comment 3 Matthew Truch 2010-11-22 21:52:40 UTC
Yes, I was one directory up from where I should have been (which I figured out after I had submitted the bug report since ABRT popped up).

Comment 4 Jesse Keating 2010-11-22 22:25:18 UTC
Ok, I think I have a duplicate of this bug somewhere, I"ll have to find it.

Comment 5 Jesse Keating 2010-12-01 22:38:43 UTC
Couldn't find a dupe, but is related to #656897

Comment 6 Jesse Keating 2010-12-03 00:05:39 UTC
Found a fix for this upstream.

Comment 7 Fedora Update System 2011-01-06 18:50:33 UTC
fedora-packager-0.5.2.0-2.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/fedora-packager-0.5.2.0-2.el5

Comment 8 Fedora Update System 2011-01-06 19:01:42 UTC
fedora-packager-0.5.2.0-2.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/fedora-packager-0.5.2.0-2.fc13

Comment 9 Fedora Update System 2011-01-06 19:04:03 UTC
fedora-packager-0.5.2.0-2.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/fedora-packager-0.5.2.0-2.fc14

Comment 10 Fedora Update System 2011-01-07 17:35:38 UTC
fedora-packager-0.5.2.0-2.el5 has been pushed to the Fedora EPEL 5 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update fedora-packager'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/fedora-packager-0.5.2.0-2.el5

Comment 11 Fedora Update System 2011-01-19 21:04:29 UTC
fedora-packager-0.5.2.0-2.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2011-01-31 15:52:38 UTC
fedora-packager-0.5.2.0-2.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 13 Fedora Update System 2011-01-31 19:55:18 UTC
fedora-packager-0.5.2.0-2.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.