Bug 655583 - [abrt] midori-0.2.8-1.fc14: sqlite3_clear_bindings: Process /usr/bin/midori was killed by signal 11 (SIGSEGV)
Summary: [abrt] midori-0.2.8-1.fc14: sqlite3_clear_bindings: Process /usr/bin/midori w...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: midori
Version: 14
Hardware: x86_64
OS: Unspecified
low
medium
Target Milestone: ---
Assignee: Peter Gordon
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:f17c6165f954a91a5bec32f9165...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-11-21 20:11 UTC by Kvikende
Modified: 2011-01-19 21:07 UTC (History)
3 users (show)

Fixed In Version: midori-0.2.9-4.fc14
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-01-19 21:07:01 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (32.41 KB, text/plain)
2010-11-21 20:11 UTC, Kvikende
no flags Details
Updated backtrace (24.46 KB, text/plain)
2010-11-22 22:49 UTC, Kvikende
no flags Details

Description Kvikende 2010-11-21 20:11:53 UTC
abrt version: 1.1.13
architecture: x86_64
Attached file: backtrace
cmdline: /usr/bin/midori -a http://www.vg.no/reise/artikkel.php?artid=10019382
component: midori
crash_function: sqlite3_clear_bindings
executable: /usr/bin/midori
kernel: 2.6.35.6-48.fc14.x86_64
package: midori-0.2.8-1.fc14
rating: 4
reason: Process /usr/bin/midori was killed by signal 11 (SIGSEGV)
release: Fedora release 14 (Laughlin)
time: 1290370013
uid: 500

How to reproduce
-----
1. Open private browsing
2. Press the down arrow in the URL bar
3. Watch it crash

Comment 1 Kvikende 2010-11-21 20:11:55 UTC
Created attachment 461865 [details]
File: backtrace

Comment 2 Kevin Fenzi 2010-11-21 20:24:31 UTC
I can't duplicate this here, but I am using a newer midori/webkitgtk/and no flash. ;) 

Can you: 

a) uninstall flash and see if it re-occurs. 

b) try 'yum --enablerepo=updates-testing update webkitgtk' and restart midori and see if it happens

Comment 3 Kvikende 2010-11-22 07:00:50 UTC
Thank you for answering. Normally nobody answers my bugreports like these. :)

It is still reproducible after both uninstalling flash player and upgrading webkitgtk.

Comment 4 Kevin Fenzi 2010-11-22 20:03:42 UTC
Same backtrace?

Some more things to try: 

1) Does it happen in non private browsing?

2) do you have java-1.6.0-openjdk-plugin installed? If you uninstall that does it make any difference?

Comment 5 Kvikende 2010-11-22 22:49:19 UTC
Created attachment 462168 [details]
Updated backtrace

I've uninstalled flash player and openjdk.

This only happens on private browser mode. It works fine in normal mode.

Comment 6 Kevin Fenzi 2010-11-23 00:06:21 UTC
Can you try this midori scratch build: 

http://koji.fedoraproject.org/koji/taskinfo?taskID=2617792

Comment 7 Kvikende 2010-11-23 08:13:01 UTC
I can no longer reproduce it in that scratch build. It seems to be fixed in 2.9.

Comment 8 Fedora Update System 2011-01-09 20:31:32 UTC
midori-0.2.9-4.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/midori-0.2.9-4.fc14

Comment 9 Fedora Update System 2011-01-10 21:29:01 UTC
midori-0.2.9-4.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update midori'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/midori-0.2.9-4.fc14

Comment 10 Fedora Update System 2011-01-19 21:06:51 UTC
midori-0.2.9-4.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.