This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 655598 - No VNC server works on a resolution higher than 1440x900
No VNC server works on a resolution higher than 1440x900
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: tigervnc (Show other bugs)
13
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Adam Tkac
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-11-21 17:22 EST by Nicholas Patrick (Peter) Solin Jr.
Modified: 2013-04-30 19:47 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-04-12 08:10:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Screenshot of a VNC connection. (414.87 KB, image/jpeg)
2010-11-21 17:22 EST, Nicholas Patrick (Peter) Solin Jr.
no flags Details

  None (edit)
Description Nicholas Patrick (Peter) Solin Jr. 2010-11-21 17:22:37 EST
Created attachment 461881 [details]
Screenshot of a VNC connection.

Description of problem:
I tried to use vino, x11vnc, and tigervnc to view my desktop on a 1680x1050 resolution, none of them worked. 

Version-Release number of selected component (if applicable):
vino-2.28.2-1.fc13
x11vnc-0.9.8-14.fc13
tigervnc-server-1.0.90-0.15.20100420svn4030.fc13

How reproducible:
Reproducible so long as the user has a monitor to support a large enough resolution.

Steps to Reproduce:
1. Set the resolution higher than 1440x900.
2. Install and run a VNC server.
3. Connect to the VNC server from another computer.
  
Actual results:
The screen displays complete static/gibberish. The mouse can still click objects but the user has no idea which object is which.

Expected results:
The screen should display without the corruption.

Additional info:
May have a relation to bug 653270.
Comment 1 Nicholas Patrick (Peter) Solin Jr. 2010-11-23 16:46:32 EST
Why was this changed to tigervnc? I only tested it on tigervnc once, and have tested it on vino and x11vnc a plethora of times (with vino much higher still than x11vnc). This bug applies to VNC servers as a whole, not a single VNC server.
Comment 2 Bill Nottingham 2010-11-23 20:51:08 EST
Because tigervnc is what we ship. The 'vnc' component is a legacy component from much older Fedora releases.
Comment 3 Nicholas Patrick (Peter) Solin Jr. 2010-11-23 21:47:07 EST
Ah, thank you. Sorry for the trouble then.
Comment 4 Adam Tkac 2011-04-12 08:10:25 EDT
This is a bug in the Windows viewer, not in the TigerVNC server.

Upstream report: https://sourceforge.net/tracker/?func=detail&aid=2873675&group_id=254363&atid=1126848

Closing as notabug.

Note You need to log in before you can comment on or make changes to this bug.