Bug 655604 - F14 install blank screen after install option selected
Summary: F14 install blank screen after install option selected
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 14
Hardware: i386
OS: Linux
low
high
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-11-21 22:52 UTC by Philip Walden
Modified: 2012-08-16 18:44 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-08-16 18:44:38 UTC


Attachments (Terms of Use)
preupgrade grub.conf (1.00 KB, application/octet-stream)
2010-11-23 00:09 UTC, Philip Walden
no flags Details
lshw output (11.61 KB, text/plain)
2010-12-08 19:37 UTC, Philip Walden
no flags Details

Description Philip Walden 2010-11-21 22:52:22 UTC
Description of problem:
I am trying to use a F14 network install CD to upgrade on an old HP Pavilion 9695C (Athalon 850MHz, nVidia NV5 RIVA TNT2/TNT2 Pro AGP) with F12 on it. This same disk successfully upgraded a HP Omnibook 6000 with F12 and a HP Pavillion 750n with a nVidia NV AGP.

I boot with the network install CD and get the initial menu to select to install/upgrade, install using basic video driver, etc. After selecting either upgrade or basic video driver install, I see the CD being read, then nothing, just a blank screen.

I had a similar problem with F12 network install on this machine. So I tried adding "vga=0x318 nomodeset" to the upgrade boot options. The only difference is a quick flash on the screen, then a blinking "underscore character" cursor.

The "install using basic video driver" has the same result.

Have also tried:

    * linux nofb
    * vga=791 [nomodeset]
    * vga=1 [nomodeset]
    * xdriver=nv nomodeset
    * xdriver=vesa nomodeset

However, I always end up with a blank screen or blank screen with blinking underscore cursor.

I know this particular AGP has problems with the nouveau driver. On F12 I had to force it to use the nv driver. I submitted a bug 612301 but there was no interest on it as this was F12 and F13 was the latest at the time. I did try to upgrade to F13, but ran into this same problem. I was hoping F14 would be better. I cannot provide logs as the system never responds after the install option is selected.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Insert F14 network install CD in boot CD drive
2. Boot computer
3. Select upgrade
  
Actual results:
CD read, then nothing, just a blank screen.


Expected results:
Next upgrade screen, such as check media, etc


Additional info:

See: https://bugzilla.redhat.com/show_bug.cgi?id=611880

Comment 1 Ben Skeggs 2010-11-21 23:02:19 UTC
This can't be nouveau if basic video driver is selected, nouveau is not used in this case.

Comment 2 Philip Walden 2010-11-21 23:20:42 UTC
I was very unsure of what component to lodge this bug against. I thought it was related to my old nVidia card, hence I used nouveau per the problem reported in bug 612301. Ben, you have helped me before (bug 555202), please suggest a path forward.

Comment 3 Ben Skeggs 2010-11-21 23:43:02 UTC
It's very hard to say without knowing more (logs etc) about why it's hanging on boot.  But, due to the nature of the hang, it's also very difficult to get that information!

I'd probably assign this to the kernel to start off with however.

Comment 4 Philip Walden 2010-11-22 15:18:31 UTC
Changed to Kernel per  Ben Skeggs' suggestion

Comment 5 Philip Walden 2010-11-23 00:05:47 UTC
Someone suggested I was running into a Common F14 Bugs: "" which suggested using the preupgrade method.

The preugrade downloaded and packaged every thing. I then added the xdriver=vesa nomodeset options to the kernel line. On reboot, I select the upgrade from the boot menu and then nothing...a blank screen.

grub.conf attached.

Comment 6 Philip Walden 2010-11-23 00:09:56 UTC
Created attachment 462182 [details]
preupgrade grub.conf

Comment 7 Philip Walden 2010-11-23 00:34:11 UTC
Also tried:

<No additional kernel options>
vga=0x318 nomodeset

Comment 8 Philip Walden 2010-12-08 19:37:43 UTC
Created attachment 467559 [details]
lshw output

Comment 9 Philip Walden 2010-12-08 19:38:19 UTC
I tried the F14 Live Desktop CD to see if I could get any details about this problem.

I got virtually the same response. Both the Boot and Boot with basic video driver quickly yielded a gray screen. No messages, no disk activity, no CD drive activity, no operational keys, etc. Pressing the power button immediately went to a power off state implying the processor was not exercising any control.

Attached a lshw output in case anyone can spot something.

Comment 10 Kyle McMartin 2010-12-09 16:56:24 UTC
Try booting with "noapic acpi=off" and see if it gets any farther?

Comment 11 Philip Walden 2010-12-10 17:39:13 UTC
Actually I have tried "noapic acpi=off" earlier, but I tried it again. Again no progress. I have tried all combinations of xdriver=vesa|nv, nomodeset, vga=0x318|741, blacklist nouveau.

However, I do not know why, but there is now a boot message on the console (looks like the first character is clipped off):

"robing EDD (edd=off to disable)... ok"

After that all boot activity ceases.

Comment 12 Philip Walden 2010-12-10 18:14:25 UTC
I tried adding edd=off to see what would happen. The only difference was that the "probing" message did not appear. I presume it just skipped the probe and then went to the hang condition.

Comment 13 Kyle McMartin 2010-12-10 18:22:19 UTC
Try passing initcall_debug and seeing which initcall hangs?

--Kyle

Comment 14 Philip Walden 2010-12-10 23:15:59 UTC
Added initcall_debug and there was no additional information or activity displayed after the "robing EDD (edd=off to disable)... ok" message.

The exact kernel line used was:

kernel /upgrade/vmlinuz preupgrade repo=hd::/var/cache/yum/preupgrade ks=hd:UUID=971175c9-6c7e-4e3e-a032-c8b81564a3cb:/upgrade/ks.cfg stage2=http://mirror.steadfast.net/fedora/releases/14/Fedora/i386/os/images/install.img xdriver=vesa nomodeset initcall_debug

Comment 15 Fedora End Of Life 2012-08-16 18:44:40 UTC
This message is a notice that Fedora 14 is now at end of life. Fedora 
has stopped maintaining and issuing updates for Fedora 14. It is 
Fedora's policy to close all bug reports from releases that are no 
longer maintained.  At this time, all open bugs with a Fedora 'version'
of '14' have been closed as WONTFIX.

(Please note: Our normal process is to give advanced warning of this 
occurring, but we forgot to do that. A thousand apologies.)

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, feel free to reopen 
this bug and simply change the 'version' to a later Fedora version.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we were unable to fix it before Fedora 14 reached end of life. If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora, you are encouraged to click on 
"Clone This Bug" (top right of this page) and open it against that 
version of Fedora.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping


Note You need to log in before you can comment on or make changes to this bug.