Bug 655610 - [abrt] geeqie-1.0-4.fc14: ERROR:filedata.c:693:file_data_unref_debug: assertion failed: (fd->magick == 0x12345678) (SIGABRT)
Summary: [abrt] geeqie-1.0-4.fc14: ERROR:filedata.c:693:file_data_unref_debug: asserti...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: geeqie
Version: 14
Hardware: x86_64
OS: Unspecified
low
medium
Target Milestone: ---
Assignee: Michael Schwendt
QA Contact: Fedora Extras Quality Assurance
URL: https://sourceforge.net/tracker/?func...
Whiteboard: abrt_hash:40b92b4d198f032f444ad1d8c5e...
: 696297 701008 746478 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-11-21 23:27 UTC by Andrew Gaul
Modified: 2012-08-14 11:03 UTC (History)
3 users (show)

Fixed In Version: geeqie-1.0-9.fc14
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-08-14 11:03:02 UTC


Attachments (Terms of Use)
File: backtrace (10.77 KB, text/plain)
2010-11-21 23:27 UTC, Andrew Gaul
no flags Details

Description Andrew Gaul 2010-11-21 23:27:55 UTC
abrt version: 1.1.13
architecture: x86_64
Attached file: backtrace
cmdline: geeqie
component: geeqie
crash_function: raise
executable: /usr/bin/geeqie
kernel: 2.6.35.6-48.fc14.x86_64
package: geeqie-1.0-4.fc14
rating: 4
reason: Process /usr/bin/geeqie was killed by signal 6 (SIGABRT)
release: Fedora release 14 (Laughlin)
time: 1290381804
uid: 500

How to reproduce
-----
1. removed a few images in bash
2. observed geeqie crash when auto-refreshing directory

Comment 1 Andrew Gaul 2010-11-21 23:27:57 UTC
Created attachment 461888 [details]
File: backtrace

Comment 2 Michael Schwendt 2010-11-22 12:38:56 UTC
> How to reproduce

Unfortunately, it's very hard to reproduce. I know it's been like that since its predecessor GQview and certainly up to and including Geeqie 1.0 alpha. It'll need somebody to review and (likely) redesign the entire directory/file loading.

Comment 3 Michael Schwendt 2011-03-05 10:33:57 UTC
It could be that a related fix to handling of sidecar files (bug 632243) that also affects crashes in FileData reference counting also fixes this. Test update following shortly...

Comment 4 Fedora Update System 2011-03-05 10:44:40 UTC
geeqie-1.0-9.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/geeqie-1.0-9.fc14

Comment 5 Fedora Update System 2011-03-05 23:02:18 UTC
geeqie-1.0-9.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update geeqie'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/geeqie-1.0-9.fc14

Comment 6 Fedora Update System 2011-03-13 21:19:26 UTC
geeqie-1.0-9.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 7 Michael Schwendt 2011-04-13 20:26:55 UTC
*** Bug 696297 has been marked as a duplicate of this bug. ***

Comment 8 Michael Schwendt 2011-04-14 13:05:04 UTC
What file types are involved here?
File grouping enabled/disabled?
What sorting in the file list?

Comment 9 Peter Hanecak 2011-04-14 15:43:00 UTC
file types involved: .jpg and .cr2

~/.geeqie/geeqierc:

metadata.sync_grouped_files: true

file_sort.method: 1
file_sort.ascending: true
file_sort.case_sensitive: false

Comment 10 Michael Schwendt 2011-04-15 12:25:51 UTC
Thanks. So, JPG+CR2 again.

I don't know how difficult it is for you to reproduce the crash, but please download and update to this test-build (preferably including the -debuginfo pkg):

  http://koji.fedoraproject.org/koji/taskinfo?taskID=3001653

It's a scratch-build and available for a limited number of days. It would be interesting to hear whether that build still crashes in the same way.

Comment 11 Peter Hanecak 2011-04-15 21:25:50 UTC
I took a source RPM of the updated geeqie package as the x86_64 one requires libexiv2.so.10 (I can get that too from Koji) but that would break quite a lot of other packages I have installed. So ... I rebuild the sopurce RPM and installed that.

Result: I redid hopefully same stuff as when the crash occured previously. This time without problem.

Comment 12 Michael Schwendt 2011-04-15 21:33:34 UTC
The new libexiv2 is because of a planned upgrade for F-14 that requires lots of rebuilds including geeqie:

  https://admin.fedoraproject.org/updates/search/exiv2

The new exiv2 is tagged into the koji buildroot for F-14, so all needed updates can be prepared, but that hasn't been trouble-free as can be read at above ticket in the Fedora Updates System "bodhi".

Comment 13 Michael Schwendt 2011-08-09 16:59:37 UTC
*** Bug 701008 has been marked as a duplicate of this bug. ***

Comment 14 Michael Schwendt 2011-08-09 17:01:41 UTC
Assuming that the geeqie-1.0-10.fc14 update has helped here, because there haven't been any dupes since then.

Comment 15 Michael Schwendt 2011-10-16 14:01:38 UTC
[reopening since this is the original backtrace and the link to the upstream ticket]

Comment 16 Michael Schwendt 2011-10-16 14:07:47 UTC
*** Bug 746478 has been marked as a duplicate of this bug. ***

Comment 17 Michael Schwendt 2011-10-16 18:08:41 UTC
For anyone who can simulate personal usage patterns to reproduce this, the full output of "geeqie --debug=255" for the crash might be interesting.

Comment 18 Fedora Update System 2011-10-16 23:08:44 UTC
geeqie-1.0-13.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/geeqie-1.0-13.fc14

Comment 19 Fedora Update System 2011-11-12 03:28:17 UTC
geeqie-1.0-13.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.