Bug 65563 - Errata imap-2001a-1.72.0 overwrites old xinetd config files
Errata imap-2001a-1.72.0 overwrites old xinetd config files
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: imap (Show other bugs)
7.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: John Dennis
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-27 12:58 EDT by Bernd Bartmann
Modified: 2014-01-21 17:48 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-04 23:31:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bernd Bartmann 2002-05-27 12:58:40 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.79 [de] (X11; U; Linux 2.4.18-4 i686)

Description of problem:
The errata imap-2001a-1.72.0 for RedHat 7.2 and imap-2001a-1.70.0 for RedHat 7.0
both overwrite the xinetd config files for imaps and pop3s. For imap, ipop2 and
ipop3 correct *.rpmnew files are created.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. change some values in /etc/xinetd.d/imaps
2. apply errata imap-2001a-1.72.0
3. look in /etc/xinetd.d and verify that your config file is overwritten (the
update should have created a imaps.rpmnew file)
	

Actual Results:  In /etc/xinetd.d:
imap.rpmnew, ipop2.rpmnew and ipop3.rpmnew are created, but
imaps and pop3s are simply overwritten

Expected Results:  imaps.rpmnew and pop3s.rpmnew should be created

Additional info:
Comment 1 Mike A. Harris 2002-05-28 04:07:53 EDT
This is done on purpose due to a problem where older imaps/pop3s was
implemented using stunnel, whereas now UW imap supports SSL internally.

If a user had used the older stunnel based implementation, and modified
the config files, then when it got upgraded to the new imap, everything
broke because the old config files used stunnel.  As such, a forced update
is necessary.

It may be possible to detect this in another way, and work around the
problem by using a post script perhaps.  I'll have to look in to that.
Comment 2 Seth Vidal 2002-05-30 21:56:50 EDT
problem: 7.2 and 7.1 systems will then have their imaps servers and ipop3
servers disabled on upgrade b/c the imaps and pop3s are off by default.

might be worth chkconfig --list imap and ipop3 and enabling imaps and ipop3s if
they are turned on.
Comment 3 Seth Vidal 2004-05-04 23:31:18 EDT
uw-imap no longer shipped this is moot

Note You need to log in before you can comment on or make changes to this bug.