Bug 65564 - (SOUND OPL3SAX)opl3sax sound card dead after suspend
Summary: (SOUND OPL3SAX)opl3sax sound card dead after suspend
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
(Show other bugs)
Version: 7.3
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-05-27 17:03 UTC by Gerald Teschl
Modified: 2007-04-18 16:42 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-11-14 21:16:23 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Gerald Teschl 2002-05-27 17:03:13 UTC
I have a laptop with an opl3sax based sound card. If I suspend the laptop
to disk and wake it up, the sound card will be dead. Even if I unload all
sound modules before suspend, I cannot load them again after resume.
This worked fine under redhat 7.2 (it is not a hardware problem since it
still works under windows).

Comment 1 Arjan van de Ven 2002-05-28 08:19:12 UTC
can you try adding "resume=force" as kernel option (eg at the end of the
/etc/grub/grub.conf line or as append line in lilo.conf if you use lilo)?

Comment 2 Gerald Teschl 2002-05-28 17:40:21 UTC
resume=force seems to make no difference. After the resume all entries
in /proc/isapnp for irq show 255, for ports 0xffff, etc.

If I try to configure the correct values by writing the appropriate commands to
/proc/isapnp, I get no errors, but the values do not change.

Comment 3 Gerald Teschl 2002-06-03 12:09:43 UTC
If I compile isapnp support as a module I have the same problem, but
if I remove the opl3sa2 and isa-pnp modules (even after resume) and
insert them again, everything works fine.

Comment 4 Gerald Teschl 2003-11-14 21:16:23 UTC
I don't have this hardware anymore and I guess its not worth
leaving this open.


Note You need to log in before you can comment on or make changes to this bug.