Bug 655672 - Monitor with invalid EDID cannot be used (but was working previously).
Summary: Monitor with invalid EDID cannot be used (but was working previously).
Keywords:
Status: CLOSED DUPLICATE of bug 533632
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati
Version: 14
Hardware: x86_64
OS: Linux
low
urgent
Target Milestone: ---
Assignee: Jérôme Glisse
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-11-22 05:30 UTC by Robert Park
Modified: 2018-04-11 18:58 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-11-26 18:41:01 UTC
Type: ---


Attachments (Terms of Use)
dmesg output (124.68 KB, text/plain)
2010-11-23 00:58 UTC, Robert Park
no flags Details
/var/log/messages (775.05 KB, text/plain)
2010-11-23 01:00 UTC, Robert Park
no flags Details
/var/log/Xorg.0.log (402.79 KB, text/plain)
2010-11-23 01:01 UTC, Robert Park
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Launchpad 539851 0 None None None Never

Description Robert Park 2010-11-22 05:30:20 UTC
Description of problem:

I originally had a dual-head setup using an Nvidia GTS 250, both monitors worked fine, using binary nvidia driver. I wanted to switch to a card that was supported by open drivers, so I bought myself an ATI Radeon 4670. After installing the card, I decided to reinstall Fedora (due to an unrelated problem with my previous install). 

Booting the Fedora 14 x86_64 liveCD, both screens worked successfully (same image on both screens). The install proceeded without incident. 

Upon first boot, both screens were still working. I then proceeded to install all the available updates, including a kernel update.

After rebooting, one of my screens was no longer able to work. It would show the BIOS screen, and then as soon as fedora began loading, one screen just shut right off. The system booted up fine, but with only one screen. Helpfully, the login screen was being displayed on the blank screen, so I could not see my way to log in. I was able to Ctrl+Alt+F2 and get a terminal to log in and check around, and I saw that the system was running fine, just the one screen was gone.

Anyway, I eventually guessed my way into logging in, and was able to use my system with just one screen (keep in mind the same blank screen worked not only with open radeon drivers on a fresh, unupdated fedora install, but also with binary nvidia drivers too).

I found some errors in dmesg, which I googled, and found some other people experiencing something similar on Ubuntu. Their workaround was to disable KMS, which I tried, but I still experienced the same problem even with UMS.

Version-Release number of selected component (if applicable):

$ uname -a
Linux schwarze-witwe 2.6.35.6-48.fc14.x86_64 #1 SMP Fri Oct 22 15:36:08 UTC 2010 x86_64 x86_64 x86_64 GNU/Linux

$ yum list installed|grep drv-ati
xorg-x11-drv-ati.x86_64            6.13.1-0.3.20100705git37b348059.fc14

$ lspci|grep Radeon
01:00.0 VGA compatible controller: ATI Technologies Inc RV730XT [Radeon HD 4670]


How reproducible: Always


Steps to Reproduce:
1. Install fresh Fedora 14 system
2. Update kernel
3. Reboot
  
Actual results: Perfectly functioning monitor receives no signal.


Expected results: Monitor ought to get a signal, no?


Additional info:

found this in /var/log/messages:

Nov 21 09:54:58 schwarze-witwe kernel: [  262.794009] [drm:drm_edid_block_valid] *ERROR* EDID checksum is invalid, remainder is 107
Nov 21 09:54:58 schwarze-witwe kernel: [  262.794016] [drm:drm_edid_block_valid] *ERROR* Raw EDID:
Nov 21 09:54:58 schwarze-witwe kernel: [  262.794050] 
Nov 21 09:54:58 schwarze-witwe kernel: [  262.796090] [drm:radeon_dvi_detect] *ERROR* DVI-I-1: probed a monitor but no|invalid EDID
Nov 21 09:54:58 schwarze-witwe kernel: [  263.352157] [drm:drm_edid_block_valid] *ERROR* EDID checksum is invalid, remainder is 226
Nov 21 09:54:58 schwarze-witwe kernel: [  263.352159] [drm:drm_edid_block_valid] *ERROR* Raw EDID:
Nov 21 09:54:58 schwarze-witwe kernel: [  263.352173] 
Nov 21 09:54:58 schwarze-witwe kernel: [  263.354184] [drm:radeon_dvi_detect] *ERROR* DVI-I-1: probed a monitor but no|invalid EDID

Let me know if there's any other information you need. I've seen similar bug reports but none for which UMS didn't fix the problem, so I'm not sure if this is quite the same or not.

Comment 1 Matěj Cepl 2010-11-22 17:54:33 UTC
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please add drm.debug=0x04 to the kernel command line, restart computer, and attach

* your X server config file (/etc/X11/xorg.conf, if available),
* X server log file (/var/log/Xorg.*.log)
* output of the dmesg command, and
* system log (/var/log/messages)

to the bug report as individual uncompressed file attachments using the bugzilla file attachment link above.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.

Comment 2 Robert Park 2010-11-23 00:58:09 UTC
Created attachment 462193 [details]
dmesg output

Comment 3 Robert Park 2010-11-23 01:00:07 UTC
Created attachment 462194 [details]
/var/log/messages

Comment 4 Robert Park 2010-11-23 01:01:26 UTC
Created attachment 462195 [details]
/var/log/Xorg.0.log

Comment 5 Robert Park 2010-11-23 01:05:41 UTC
Thanks for the quick reply. I have no /etc/X11/xorg.conf, however. Is there some other file you'd like instead?

$ ls /etc/X11/
applnk  fontpath.d  prefdm  xinit  Xmodmap  xorg.conf.d  Xresources

Comment 6 Robert Park 2010-11-23 01:10:34 UTC
Oh, also, when I am in System->Preferences->Monitors menu, the blanked screen is given the name of the other screen. That is, both screens are listed as being the same make & model (they aren't), even though the Monitors dialog correctly lists the available resolutions for each screen. I'm forced to identify them by the available resolutions than by their actual names. That bug has been happening since before the screen stopped working.

Maybe that information is useful.

Thanks again.

Comment 7 Robert Park 2010-11-23 23:56:14 UTC
Uh, so I was playing with the Monitors dialog a bit, and I've tricked my one screen into working by setting the resolution lower than the native resolution. I'm not sure why that would make any difference whatsoever, but there you have it. 

Of course, it would be nice if this could be fixed so that I can run this monitor at it's native resolution.

Thanks.

Comment 8 Matěj Cepl 2010-11-26 18:41:01 UTC

*** This bug has been marked as a duplicate of bug 533632 ***


Note You need to log in before you can comment on or make changes to this bug.