Bug 655700 - Suspend failure with kernel 2.6.35.6-48.fc14.x86_64
Summary: Suspend failure with kernel 2.6.35.6-48.fc14.x86_64
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 14
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-11-22 08:23 UTC by Simon Goodall
Modified: 2011-10-19 14:54 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-10-18 13:57:56 UTC
Type: ---


Attachments (Terms of Use)
lspci -vvv entry for dell e6500 (16.57 KB, text/plain)
2010-11-22 08:23 UTC, Simon Goodall
no flags Details

Description Simon Goodall 2010-11-22 08:23:31 UTC
Created attachment 461940 [details]
lspci -vvv entry for dell e6500

Description of problem:
With kernel 2.6.35.6-48.fc14.x86_64, my machine fails to fully enter suspend to ram.
It appears to powerdown everything - all indicator lights turn off, display turns off and there is no response to the keyboard including sys-rq. However the powerlight is still on solid.
Pressing the power button does not wake the machine and all I can do is poweroff the machine by holding down the power button.

The previous kernel (2.6.35.6-45.fc14.x86_64) does not have this issue.

I have a Dell Latitude e6500 with an intel gfx card. I note the change log entry for kernel 2.6.35.6-48.fc14.x86_64 has display related patches.


Version-Release number of selected component (if applicable):
kernel-2.6.35.6-48.fc14.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Close laptop lid or press suspend button
2.
3.
  
Actual results:
Machine appears to suspend, but has solid power light and becomes unresponsive

Expected results:
Machine suspends to ram, has flashing power light and can be resume by pressing power button.

Additional info:

Comment 1 Simon Goodall 2010-12-17 15:22:36 UTC
After further testing, this does not appear to be linked to a specific kernel version.
Suspend/Resume was very reliable in F13 - and appeared stable in F14 to start with.
I have also tried hibernation and this also fails to finish the cycle. I.e. it never powers off and rebooting enters a normal boot up sequence rather than resuming.

I also tried running pm-suspend --quirk-none (as currently it seems to fall back to all) and this seemed to help a little, but not conclusively.


I also upgraded my bios version sometime after my f14 upgrade from A19 (or possibly A22) to A24. There does appear to be a video firmware update included which may be related. Unfortunately, downgrading the bios does not downgrade the video firmware. Downgrading to A19 (minus video downgrade) does not solve the problem.


I also tried using the pm_trace mode in the kernel, but this did not yield consistent results. one time it reported a usb 1.1 hub as the last device, another time nothing was reported against the magic number.


Are there any suggestions I can try for tracking down the issue?

Comment 2 Neil Kay 2010-12-21 21:35:08 UTC
FYI: Acer Aspire 5735. Symptoms exactly as described above with Fedora 14, Kernel 2.6.35.9-64.fc14.x86_64, but no problems with previous kernel 2.6.35.6-48.fc14.x86_64.

Happy to provide any useful info - say what you need.

Comment 3 Simon Goodall 2010-12-22 08:27:38 UTC
I've made some room on my disk and installed F13 again. Suspend/resume has worked flawlessly for nearly 5 days now - 4 of which have been using the F14 kernel 2.6.35.9-64.fc14.x86_64.

So this indicates it is a problem in F14 but not (directly) the kernel or the BIOS version.

Comment 4 Simon Goodall 2011-01-01 20:22:16 UTC
I've now changed my F14 installation to use F13 xorg-* rpms and also the various mesa rpms too (my system froze after a little while before I did this).

Since then, my F14 has had no suspend failures over about 3 days running time.

Comment 5 Josh Boyer 2011-09-21 17:12:36 UTC
Is this still happening on a fully updated F14?

Comment 6 Simon Goodall 2011-10-18 11:43:34 UTC
I have long since upgraded to F15 where this problem is not present.

Comment 7 Josh Boyer 2011-10-18 13:57:56 UTC
Thank you for letting us know.


Note You need to log in before you can comment on or make changes to this bug.