Bug 655808 - jetty installs pom files with incorrect filename
Summary: jetty installs pom files with incorrect filename
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: jetty
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnston
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-11-22 13:39 UTC by Stanislav Ochotnicky
Modified: 2010-12-01 21:31 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-12-01 21:31:50 UTC
Type: ---


Attachments (Terms of Use)

Description Stanislav Ochotnicky 2010-11-22 13:39:15 UTC
Pom files for jetty seem to be installed with different name than what is advertised in add_to_maven_depmap macro call. Missing/wrong pom filenames are:
jetty.noarch: W: pom-not-found JPP-tomcat6-servlet-2.5-api.pom

Comment 1 Jeff Johnston 2010-11-30 19:35:44 UTC
Could you please elaborate?  jetty doesn't own or attempt to install the pom in question (i.e. it is not a wrong filename or missing filename).  Should this bug be closed?

Comment 2 Alexander Kurtakov 2010-12-01 07:56:37 UTC
jetty-util.pom is the only installed pom that references org.mortbasy.jetty:servlet-api it would be best to replace it with javax.servlet:servlet-api in the pom

Comment 3 Stanislav Ochotnicky 2010-12-01 13:07:34 UTC
FYI the problem is with this call:
%add_to_maven_depmap org.mortbay.jetty servlet-api %{version} JPP tomcat6-servlet-2.5-api

This call tells us that there should be tomcat6-servlet-2.5-api jar file and JPP-tomcat6-servlet-2.5.api.pom file. These files are present in tomcat6 package not jetty though. There are 2 normal solutions:
 1. Fix pom file of jetty to use normal javax.servlet:servlet-api depmap
 2. move the depmap call to tomca6. 

The first approach is better IMO, since this depmap is quite unique...

Comment 4 Jeff Johnston 2010-12-01 21:31:50 UTC
A fix has been made to do option 1 above and a build has been done in rawhide.


Note You need to log in before you can comment on or make changes to this bug.