Bug 65583 - compress options don't work if there's a space between the flag and its parameter
compress options don't work if there's a space between the flag and its param...
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: dump (Show other bugs)
7.3
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Mike A. Harris
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-27 21:24 EDT by Michael Wardle
Modified: 2007-04-18 12:42 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-29 22:29:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Michael Wardle 2002-05-27 21:24:27 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.0rc2)
Gecko/20020512 Netscape/7.0b1

Description of problem:
I just filed this bug against dump on the SourceForge dump bug tracker.  I
observed this on a Pentium III system with the version of dump supplied in Red
Hat Linux 7.3.

-----
If a compression option such as -j or -z is selected,
the optional compression level argument is treated as a
file name is there is a space between the switch and
its argument.

For instance:
/sbin/dump -0 -z 4 -f /disk1/backup/root.dump /
=>
...
DUMP: Cannot open 4

The dump manual page suggests that a space is
acceptable, as it states the option is:
[-z compression level]

Other options (such as -A -B -f) all work with a space
between the switch and its argument. Please make the
compression options do the same.

Observed in dump 0.4b27.
-----

Version-Release number of selected component (if applicable):
0.4b27

How reproducible:
Always

Steps to Reproduce:
1. run "/sbin/dump -0 -z 4 -f /var/test.dump /"

Actual Results:  Output is:
...
DUMP: Cannot open 4
...

Presumably dump is treating "4" as the final command line parameter, rather than
as the optional parameter to "-z".


Expected Results:  Dump runs with compression level 4.

Additional info:

Removing the space between the -z and the level works.  Unfortunately, the
manual pages suggests the version with a space is the correct syntax.

"/sbin/dump -0 -z4 -f /var/test.dump /"
Comment 1 Mike A. Harris 2002-05-29 22:29:38 EDT
As long as the option actually works, I'd consider it more of an inconvenience,
or perhaps even a documentation error than a serious bug, but I'm sure you
would probably agree with it being a minor issue also.

Since you've reported it upstream, I am sure that the dump maintainers will
fix it in their next release likely, as long as they agree it is a bug.
Rather than duplicate the effort, I'm inclined to just wait for the next
release of dump to hit the streets, and I'll update our rawhide package
to that to pick up the fix.

We currently have dump-0.4b28 in rawhide.  You might want to test that out
and report back.  Feel free to update this report to notify me when a new
version of dump is available in case I miss it when it comes out, and I'll
update it ASAP.

Thanks.
Comment 2 Michael Wardle 2002-05-30 21:48:17 EDT
A dump developer tells me it's not easily possible to allow a space between the
switch and its optional parameter as dump uses getopt().  The documentation of
dump has been updated to explicitly mention this in version 0.4b28 and you say
it's already in Raw Hide, so I don't need you to do anything.

I'm setting the state to CLOSED-RAWHIDE.  I hope this is acceptable.

Thanks for your help

Note You need to log in before you can comment on or make changes to this bug.