Bug 65586 - xdm generates a bad .Xauthority in /var/run/xauth
xdm generates a bad .Xauthority in /var/run/xauth
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.3
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-28 00:21 EDT by Nathan G. Grennan
Modified: 2007-03-26 23:53 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-28 03:40:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nathan G. Grennan 2002-05-28 00:21:33 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.3 (X11; Linux i686; U;) Gecko/20020523

Description of problem:
Running xauth -f /var/run/xauth/<insert random name> list
shows something like  #ffff##:  MIT-MAGIC-COOKIE-1  <insert cookie here> when
with gdm it should content identical to ~/.Xauthority

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. rpm -e gdm kdm
2. init 5
3. Login as a normal user
4. run xterm
5. su - root
6. xauth -f /var/run/xauth/<insert random name> list
	

Actual Results:  Something like
#ffff##:  MIT-MAGIC-COOKIE-1 <insert cookie here>

Expected Results:  hostname:0 MIT-MAGIC-COOKIE-1 <insert cookie here>

Additional info:
Comment 1 Nathan G. Grennan 2002-05-28 00:27:22 EDT
Wrong package. Thought kdm was uninstall and was running xdm.
Comment 2 Nathan G. Grennan 2002-05-28 00:34:32 EDT
Found xdm has the same behavior, tho creates the files in a different directory.
Comment 3 Nathan G. Grennan 2002-05-28 03:40:05 EDT
I agree it is low priority. It doesn't seem to affect standard behavior, but it
must be there for some reason(or maybe not and you can simplely remove it). You
suggest using gdm, but it has it's own bugs, like bloating your path. I know hp
knows about, but haven't seen a fix for yet as far as I know. xdm/kdm seem to
fix that issue. There are /etc/profile hacks to workaround that tho problem, but
keep profile the way it comes packages is preferable since you have to port
changes from old configuration files after you upgrade a package a good part of
the time.
Comment 4 Mike A. Harris 2002-08-07 22:48:49 EDT
Closing WONTFIX as I dont see any problem here.  If there is a problem,
it should be reported and fixed by XFree86.org on xpert@xfree86.org
mailing list.  At a minimum, someone who understands xauthority information
a LOT more, needs to be a part of looking at this.

Making random uninformed changes to things is never good.


Note You need to log in before you can comment on or make changes to this bug.