Bug 65587 - qt requires on libcups.so ???
qt requires on libcups.so ???
Status: CLOSED NEXTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: qt (Show other bugs)
7.3
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-28 00:32 EDT by pogosyan
Modified: 2007-03-26 23:53 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-04 16:38:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description pogosyan 2002-05-28 00:32:38 EDT
Description of Problem:
qt rpm packages dependences are astonishing - all depend on libcups.so.2 !!
What,  particular printing system is required to use qt toolkit ?


Version-Release number of selected component (if applicable):
qt-3.0.3-11 and related qt packages

How Reproducible:


Steps to Reproduce:
1. 
2. 
3. 

Actual Results:


Expected Results:


Additional Information:
Comment 1 Bernhard Rosenkraenzer 2002-06-10 10:18:01 EDT
This is intentional.  
  
Qt is a very powerful toolkit - it includes support for printing (code-wise,  
this is very comfortable - you just treat the printer like the screen).  
  
It needs to get a list of available printers. With lpd/LPRng, the only way to  
do this is to parse /etc/printcap (and every application uses its own way to  
do that -- rather messy). With CUPS, you get libcups, and an application just  
calls a function and has a list of printers.  
  
Because of this, Qt requires the CUPS *libraries* to support printing with 
CUPS. It does NOT require the actual CUPS spooler to be used.
Comment 2 Bill Nottingham 2006-08-04 16:38:07 EDT
Red Hat Linux and Red Hat Powertools are currently no longer supported by Red
Hat, Inc. In an effort to clean up bugzilla, we are closing all bugs in MODIFIED
state for these products.

However, we do want to make sure that nothing important slips through the
cracks. If, in fact, these issues are not resolved in a current Fedora Core
Release (such as Fedora Core 5), please open a new issues stating so. Thanks.

Note You need to log in before you can comment on or make changes to this bug.