This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 655925 - Broken ttmkfdir test?
Broken ttmkfdir test?
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-font-utils (Show other bugs)
rawhide
Unspecified Unspecified
low Severity medium
: ---
: ---
Assigned To: Peter Hutterer
Fedora Extras Quality Assurance
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-11-22 12:46 EST by Jerry James
Modified: 2010-12-24 19:26 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-24 00:23:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jerry James 2010-11-22 12:46:20 EST
Description of problem:
Doing updates on my Rawhide machine this morning, I got this in the output:

  Updating       : xorg-x11-fonts-misc-7.5-3.fc15.noarch                 49/100
/usr/bin/xorg-x11-fonts-update-dirs: line 46: ttmkfdir: command not found
/usr/share/X11/fonts/encodings /
/

First, this wouldn't happen if the package had a Requires on ttmkfdir, which the xorg-x11-fonts-update-dirs script can invoke.  Second, it looks like the test for whether to run ttmkfdir is backwards:

if [ "$need_ttmkfdir" != "yes" ]; then
    ttmkfdir $fontdir
fi

So if "need_ttmkfdir" is "no", then we run ttmkfdir.  Note that the "skip_fontscale" test just above this one is similarly backwards.

Version-Release number of selected component (if applicable):
xorg-x11-font-utils-7.5-3.fc15.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Make sure ttmkfdir is not installed.
2. Run /usr/bin/xorg-x11/fonts-update-dirs
  
Actual results:
The error message reported above.

Expected results:
ttmkfdir should not have been run.

Additional info:
Comment 1 Peter Hutterer 2010-11-24 00:23:48 EST
script test fixed as suggested, the fonts that need ttmkfdir already have the requires anyway

http://koji.fedoraproject.org/koji/buildinfo?buildID=206248
Comment 2 Fedora Update System 2010-12-06 22:27:09 EST
xorg-x11-font-utils-7.4-3.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/xorg-x11-font-utils-7.4-3.fc14
Comment 3 Fedora Update System 2010-12-06 22:35:49 EST
xorg-x11-font-utils-7.2-12.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/xorg-x11-font-utils-7.2-12.fc13
Comment 4 Fedora Update System 2010-12-11 19:02:00 EST
xorg-x11-font-utils-7.4-3.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 5 Fedora Update System 2010-12-24 19:26:22 EST
xorg-x11-font-utils-7.2-12.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.