Bug 65601 - rhn_register src.rpm misses "BuildRequires"
Summary: rhn_register src.rpm misses "BuildRequires"
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rhn_register (Show other bugs)
(Show other bugs)
Version: 7.3
Hardware: i386 Linux
low
low
Target Milestone: ---
Assignee: Adrian Likins
QA Contact: Jay Turner
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-05-28 13:51 UTC by Ingo T. Storm
Modified: 2015-01-07 23:56 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-02 21:23:57 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ingo T. Storm 2002-05-28 13:51:34 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 4.01; Windows NT)

Description of problem:
I tried to rebuild the rhn_register SRC RPM. It failed, because it needs python-
devel (Python.h) and gettext (msgfmt). After installing those two rpms, it 
builds fine. ergo: python-devel and gettext should be in "BuildRequires:" 
clause.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. rpm --rebuild SRPMS/rhn_register-2.7.21-7.x.3.src.rpm 
	

Actual Results:  dmimodule.c:18:20: Python.h: No such file or directory
make: *** [dmimodule.o] Error 1

and after installing python-devel:

de.mo: make[1]: msgfmt: Command not found
make[1]: *** [de.mo] Error 127


Expected Results:  rpm should have been rebuilt

Additional info:

Comment 1 Ingo T. Storm 2002-05-28 14:58:07 UTC
up2date src.rpm is missing "BuildRequires: gettext", too. It does not need 
python-devel, though.

Comment 2 Adrian Likins 2004-09-02 21:23:57 UTC
finally updated rhn_register (2.9.13, next release), up2date should have
properly build reqs for a while


Note You need to log in before you can comment on or make changes to this bug.