Bug 656022 - fix for bug 644823 breaks smartcard screen unlock
Summary: fix for bug 644823 breaks smartcard screen unlock
Keywords:
Status: CLOSED DUPLICATE of bug 654896
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: gnome-screensaver
Version: 5.5
Hardware: x86_64
OS: Linux
high
high
Target Milestone: rc
: ---
Assignee: jmccann
QA Contact: desktop-bugs@redhat.com
URL:
Whiteboard:
Depends On:
Blocks: 640580
TreeView+ depends on / blocked
 
Reported: 2010-11-22 21:34 UTC by jared jennings
Modified: 2015-01-14 23:26 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-11-27 04:50:35 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description jared jennings 2010-11-22 21:34:08 UTC
Description of problem:
With gnome-screensaver 2.16.1-8.el5_5.1 installed, the screen is no longer unlockable with the smartcard.

Version-Release number of selected component (if applicable):
2.16.1-8.el5_5.1

Steps to Reproduce:
1. Upgrade gnome-screensaver to 2.16.1-8.el5_5.1.
2. Log out. Log in with a smartcard.
3. Lock the screen.
4. Attempt to unlock the screen.
  
Actual results:
If there is a smartcard inserted, the unlock dialog says, "Smart card inserted," and nothing more. The Cancel button works, but the screen is not unlockable.

If there is not a smartcard inserted, the unlock dialog says, "Please insert a smartcard," and does not react when a smartcard is inserted. The cancel button works.

Expected results:
If there is a smartcard inserted, the unlock dialog should say, "Please enter PIN," accept a PIN and (if correct) unlock the display.

If there is not a smartcard inserted when the dialog shows up, but then the user inserts a smartcard, the dialog should indicate that a smartcard has been inserted, and continue appropriately.


Additional info:

I've straced the gnome-screensaver-dialog process; one thread polls indefinitely and the other locks on a futex. Downgrading to 2.16.1-8.el5_5 results in the desired behavior. Have not looked at the dont-log-cancel-requests patch in detail.

Comment 1 jared jennings 2010-11-22 21:35:25 UTC
I should probably mention that we're using CACs here, not CoolKeys proper.

Comment 4 Ray Strode [halfline] 2010-11-27 04:50:35 UTC
Hi Jared,

This issue has been identified and is currently being tracked by bug 654896.  It will be addressed in a subsequent update.

Thanks.

*** This bug has been marked as a duplicate of bug 654896 ***


Note You need to log in before you can comment on or make changes to this bug.