Bug 65604 - after rebuild with gcc-3.1, rpm install fails
Summary: after rebuild with gcc-3.1, rpm install fails
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: kdelibs (Show other bugs)
(Show other bugs)
Version: 1.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: wdovlrrw
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-05-28 14:04 UTC by sean
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-29 18:59:56 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
last part of output from rpm --rebuild kdelibs-3.0.1-2 (4.08 KB, text/plain)
2002-05-29 17:15 UTC, sean
no flags Details

Description sean 2002-05-28 14:04:57 UTC
Description of Problem:
I rebuilt kdelibs with gcc-3.1-2. All went well ( or seemed to). When I tried to
install the rpm, the rpm packager couldn't find or open the files

Version-Release number of selected component (if applicable):
kdelibs-3.0.1-2.src.rpm

FWIW: rpm-4.0.4-7x.18


How Reproducible:


Steps to Reproduce:
1. rpm --rebuild

2. rpm -Uvh
3. 

Actual Results:
rpm -Uvvvh kdelibs*
D: ============== kdelibs-3.0.1-2.i386.rpm
D: Expected size:     10379982 = lead(96)+sigs(160)+pad(0)+data(10379726)
D:   Actual size:     10379982
D: opening  db environment /var/lib/rpm/Packages create:mpool
D: opening  db index       /var/lib/rpm/Packages create mode=0x42
D: locked   db index       /var/lib/rpm/Packages
D: opening  db index       /var/lib/rpm/Name create mode=0x42
D: 	added binary package [0]
D: ============== kdelibs.deps
D: ============== kdelibs-devel-3.0.1-2.i386.rpm
D: Expected size:      3504549 = lead(96)+sigs(160)+pad(0)+data(3504293)
D:   Actual size:      3504549
D: 	added binary package [1]
D: ============== error:
error: open of error: failed: No such file or directory
D: ============== failed
error: open of failed failed: No such file or directory
D: ============== dependencies:
error: open of dependencies: failed: No such file or directory
D: ============== libqtmcop-gcc2.96.so.1
error: open of libqtmcop-gcc2.96.so.1 failed: No such file or directory
D: ============== is
error: open of is failed: No such file or directory
D: ============== needed
error: open of needed failed: No such file or directory
D: ============== by
error: open of by failed: No such file or directory
D: ============== kdelibs-3.0.1-2
error: open of kdelibs-3.0.1-2 failed: No such file or directory
D: ============== libsoundserver_idl-gcc2.96.so.1
error: open of libsoundserver_idl-gcc2.96.so.1 failed: No such file or directory
D: ============== is
error: open of is failed: No such file or directory
D: ============== needed
error: open of needed failed: No such file or directory
D: ============== by
error: open of by failed: No such file or directory
D: ============== kdelibs-3.0.1-2
error: open of kdelibs-3.0.1-2 failed: No such file or directory
D: ============== libartskde-gcc2.96.so.1
error: open of libartskde-gcc2.96.so.1 failed: No such file or directory
D: ============== is
error: open of is failed: No such file or directory
D: ============== needed
error: open of needed failed: No such file or directory
D: ============== by
error: open of by failed: No such file or directory
.....
[goes on for a long time ]




Expected Results:


Additional Information:

Comment 1 Bernhard Rosenkraenzer 2002-05-28 14:09:18 UTC
This is because gcc 3.1 is not binary compatible with earlier gccs. 
 
Use --nodeps to install the package (you'll need to recompile anything using 
it afterwards). 
 
A kdelibs package built with gcc 3.1 doesn't provide lib*-gcc2.96.so.1.

Comment 2 sean 2002-05-28 16:50:54 UTC
--nodeps doesn't work. Same result. Even --force doesn't work.

I'm not an rpm maven, but as I read this output it's unable to read the rpm file
itself. That is, it's not up to checking for dependencies, it doesn't even start.

jay

Comment 3 sean 2002-05-29 17:15:16 UTC
Created attachment 58864 [details]
last part of output from rpm --rebuild kdelibs-3.0.1-2

Comment 4 Bernhard Rosenkraenzer 2002-05-29 17:19:13 UTC
Right, something else is going on here, but it's not reproducable here (see 
the rawhide kde packages for proof ;) ). 
 
By any chance, did you forget to rebuild qt and/or arts first? 


Comment 5 sean 2002-05-29 17:25:08 UTC
So I rpm -e all of kde and arts. No kdelibs*, no *gcc2.96*. rpm --rebuilddb. I
rebuild and install arts. I rebuild and try to install kdelibs - same result.

I've attached a snip from the kdelibs rebuild showing the requires. None of this
stuff is there. Why is rpm trying to open it? How does rpm even know about the
other files and programs?  This seems like some weird rpm error.

jay

Comment 6 sean 2002-05-29 18:59:50 UTC
Sorry - my comment passed yours in the ether.

I did rebuild qt with gc-3.1 , though before I erased kde. I'll rebuild it again
now that kde is all gone.

 [root@daddy include]# rpm -qa | grep 3.0.0
kdoc-3.0.0-1.cvs20020321.2


I have grep'ed /usr/lib and /usr/include for gcc2.96. Nothing.

Did you rebuild kdelibs with gcc-3.1?

jay


Comment 7 sean 2002-06-01 17:46:23 UTC
WFM now. I rebuilt qt w/o kde installed. then arts. then kdelibs-3.0.2-4. It
worked. Still puzzled by why I had the original problem, but...


Note You need to log in before you can comment on or make changes to this bug.