This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 656167 - dm-replicator documentation
dm-replicator documentation
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: doc-Logical_Volume_Manager (Show other bugs)
6.1
All Linux
low Severity medium
: rc
: ---
Assigned To: Steven J. Levine
ecs-bugs
: Documentation
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-11-23 01:41 EST by Colin Coe
Modified: 2011-06-22 18:20 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-06-16 18:58:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
A script for setting up dm-replicator base on LVM (2.16 KB, application/x-sh)
2010-11-23 01:53 EST, Gris Ge
no flags Details

  None (edit)
Description Colin Coe 2010-11-23 01:41:14 EST
Description of problem:
No (sys admin level) documentation for dm-replicator

Version-Release number of selected component (if applicable):
modinfo dm-replicator
filename:       /lib/modules/2.6.32-71.el6.x86_64/kernel/drivers/md/dm-replicator.ko
license:        GPL
author:         Heinz Mauelshagen <heinzm@redhat.com>
description:    device-mapper remote replication target
srcversion:     ECA4D2A942A25ED1F29C53F
depends:        dm-mod,dm-registry
vermagic:       2.6.32-71.el6.x86_64 SMP mod_unload modversions

How reproducible:
Always

Steps to Reproduce:
1. 
2.
3.
  
Actual results:
No documentation

Expected results:
Documentation explaining how sys admins can use dm-replicator to get replication working between sites and what tools to use should be available.

Additional info:
Comment 2 Gris Ge 2010-11-23 01:47:08 EST
Kernel doc -- Documentation/device-mapper/replicator.txt could be a good reference even through it don't cover all explanation for every parameter.
Comment 3 Gris Ge 2010-11-23 01:53:17 EST
Created attachment 462248 [details]
A script for setting up dm-replicator base on LVM

Please check this script for how to setup dm-replicator.
Comment 4 Steven J. Levine 2011-01-20 13:52:00 EST
I'm changed the component to LVM, since that's where the device mapper is documented. This doesn't seem to be about DM-Multipath documentation.
Comment 5 Steven J. Levine 2011-01-20 14:00:48 EST
Jon:

I added you to the CC list and set this to needinfo from you because I don't know what to make of this bug -- it was originally filed as a DM-Multipath documentation bug, but it seems to be more about the device mapper in general, which I document as an appendix in the LVM manual -- and which you helped me put together. That appendix is here:

http://documentation-stage.bne.redhat.com/docs/en-US/Red_Hat_Enterprise_Linux/6/html/Logical_Volume_Manager_Administration/device_mapper.html

Now, I'm not even sure what this request is for. Can you provide me with any sort of help in figuring out what it is that I'm specifically being asked to document here? Is this an additional mapping target that I should add to the device mapper appendix?

-Steven
Comment 6 Steven J. Levine 2011-04-11 15:33:05 EDT
I never got an answer to my NEEDINFO here, and this update to the documentation is not going to make the 6.1 release. I'm moving this to 6.2 and will pursue this info. It's a major documentation task and will involve allocation of documentation resources.
Comment 8 Steven J. Levine 2011-06-15 17:01:29 EDT
Jon: This is another ping on this BZ -- I'm still not sure what this bug refers to, or how to plan for addressing it in RHEL 6.2.
Comment 9 Steven J. Levine 2011-06-16 16:41:27 EDT
I have sent this note to the lvm-team mailing list:

BZ#656167 is a request to document dm-replicator.

https://bugzilla.redhat.com/show_bug.cgi?id=656167

I am unfamiliar with this, so I ask these questions of this list:

- Does it make sense to document dm-replicator in the user/admin documentation?  The bug notes that this should be documented for system administrators, but I'm looking for additional input as to whether this is something we should be documenting in the LVM/CLVM manual.

- The bug notes that Heinz Mauelshagen is the author of the dm-replicator component. If we document this, is Heinz still the technical contact I can contact to help me put together the documentation?

Any advice or comments on this would be appreciated. Thanks.

-Steven Levine
Comment 10 Steven J. Levine 2011-06-16 18:58:38 EDT
The LVM team has decided not to productive the dm-replicator at this time. drbd should meet customer needs. If this decision is re-visited, we can open a new bug to add the documentation, but since those are the current plans I am closing this bug as wontfix.
Comment 11 Steven J. Levine 2011-06-16 18:59:36 EDT
That word "productive" in Comment 10 should be "productize". Still not a great word, but at least one that makes sense in this context.

Note You need to log in before you can comment on or make changes to this bug.