Bug 656175 - [abrt] workrave-1.9.2-1.fc14: g_slist_remove: Process /usr/bin/workrave was killed by signal 11 (SIGSEGV)
Summary: [abrt] workrave-1.9.2-1.fc14: g_slist_remove: Process /usr/bin/workrave was k...
Keywords:
Status: CLOSED CANTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: workrave
Version: 14
Hardware: x86_64
OS: Unspecified
low
medium
Target Milestone: ---
Assignee: Tomas Mraz
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:d74ba67b7db7d32b4984cf06c3f...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-11-23 07:05 UTC by John
Modified: 2010-12-17 09:23 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-12-01 12:44:08 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (14.74 KB, text/plain)
2010-11-23 07:05 UTC, John
no flags Details

Description John 2010-11-23 07:05:01 UTC
abrt version: 1.1.14
architecture: x86_64
Attached file: backtrace
cmdline: /usr/bin/workrave
component: workrave
crash_function: g_slist_remove
executable: /usr/bin/workrave
kernel: 2.6.36-4.fc15.x86_64
package: workrave-1.9.2-1.fc14
rating: 4
reason: Process /usr/bin/workrave was killed by signal 11 (SIGSEGV)
release: Fedora release 14 (Laughlin)
time: 1290495179
uid: 500

How to reproduce
-----
1. After KDE crashing
2.
3.

Comment 1 John 2010-11-23 07:05:03 UTC
Created attachment 462254 [details]
File: backtrace

Comment 2 Tomas Mraz 2010-11-23 08:42:26 UTC
So KDE crashed and workrave crashed after that too? This crash looks like the DBus session bus was somehow broken which resulted in this crash.

Comment 3 Tomas Mraz 2010-12-01 12:44:08 UTC
There are some changes in the upstream repository that change the order of DBus initialization. However it is not sure whether they fix this crash. I'm closing as CANTFIX as this is intermittent crash and I cannot do much with it.

Comment 4 Tomas Mraz 2010-12-17 09:23:48 UTC
Please try new upstream version 1.9.3 which I submitted to testing updates just
now.


Note You need to log in before you can comment on or make changes to this bug.