Bug 65620 - Unhandled exception occurred during Install Upgrade
Unhandled exception occurred during Install Upgrade
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-28 14:44 EDT by William Bennecke
Modified: 2007-04-18 12:42 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-06-12 13:25:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Traceback (64.60 KB, text/plain)
2002-05-28 14:49 EDT, William Bennecke
no flags Details

  None (edit)
Description William Bennecke 2002-05-28 14:44:08 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; T312461)

Description of problem:
During the upgrade process using the installer, after the boot loader section 
an unhandled exception occurs and causes the installer to stop working.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.RedHat Linux 7.2 is rebooted with a floppy disk in the system 
containing "bootnet.img" on it.
2.The installer process is started in text mode.
3.The following sections are sucessfully gone through: Choose a Language, 
Keyboard Type, Installation Method (ftp), Configure TCP/IP (DHCP), FTP Setup 
(anonymous), Retrieving netstg1.img, Mouse Selection, Installation Type 
(Upgrade Existing System), Upgrade Partition, Customize Packages to Upgrade 
(No).
4. Section Upgrade Boot Loader configuration: Selected "Update boot loader 
configuration".
5. Screen output: "Reading package information...".
6. Exception Occurred!!
	

Actual Results:  The installation/upgrade process exited abnormally after the 
screen output of "Reading package information..".

Expected Results:  The packages should have been read and the upgrade process 
should have continued.

Additional info:

/usr/src/build/90289-i386/install/usr/lib/anaconda/comps.py, line 486, in 
readCompsFile
TypeError: comp file version 3 or 4 expected.
Comment 1 William Bennecke 2002-05-28 14:49:24 EDT
Created attachment 58785 [details]
Traceback
Comment 2 Michael Fulbright 2002-05-29 12:55:22 EDT
This is due to a damaged install source.  Have you tested your install media?
Comment 3 William Bennecke 2002-05-29 13:32:39 EDT
I have download these files under the following directories on another (not the 
RH 7.2 computer)
computer system:

Redhat--> base
             comps 
             hdlist
             hdlist2
             hdstg1.img
             netstg1.img
             stage2.img

On the Redhat 7.2 system I have ftp the "netstg1.img" file to the RH7.2 system.
Then I.
# mount /dev/fd0 /mnt/floppy
# dd if=bootnet.img of=/dev/fd0 bs=1440K
# umount /mnt/floppy

Then I rebooted RH 7.2 system to start the installer.
During the install process I selected "ftp" for the install method.
This then access the Redhat->base directory for the netstg1.img file.

Your note indicates a damaged install source.  Is this the bootnet.img or 
netstg1.img file? Or are you saying the floppy has a problem?


Comment 4 Michael Fulbright 2002-06-12 12:53:07 EDT
Reassigning to an engineer.
Comment 5 Jeremy Katz 2002-06-12 13:02:09 EDT
The files on the ftp site are likely to be corrupt, at least some of them... 
what does the top of the RedHat/base/comps file say?
Comment 6 William Bennecke 2002-06-12 13:25:01 EDT
Looks like the netstg1.img file was the problem.  It was corrup either on the 
ftp site or corrupted during the ftp.
Thanks for all the help!

Note You need to log in before you can comment on or make changes to this bug.