Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 656205 - Logical error in section 4.4.1 of Logical_Volume_Manager_Administration(EN)-6 (2010-10-14T15:20)
Summary: Logical error in section 4.4.1 of Logical_Volume_Manager_Administration(EN)-6...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: doc-Logical_Volume_Manager
Version: 6.0
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: rc
: ---
Assignee: Steven J. Levine
QA Contact: ecs-bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-11-23 08:30 UTC by Alberto Mariani
Modified: 2011-05-24 18:44 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-05-24 18:44:06 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Alberto Mariani 2010-11-23 08:30:32 UTC
Description of problem:

In section 4.4.1 "Creating Linear Logical Volumes", on page 31 it reads:

"You can specify which extents of a physical volume are to be used for a logical volume. The following example creates a linear logical volume out of extents 0 through 25 of physical volume /dev/sda1 and extents 50 through 125 of physical volume /dev/sdb1 in volume group testvg.

lvcreate -l 100 -n testlv testvg /dev/sda1:0-25 /dev/sdb1:50-125

However, the specified ranges define a total of 102 extents, which is in contrast with the argument for the '-l' option. I think the command should read

lvcreate -l 100 -n testlv testvg /dev/sda1:0-24 /dev/sdb1:50-124

and the preceding text should be adjusted accordingly.


Version-Release number of selected component (if applicable):

6.0-1

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Alberto Mariani 2010-11-23 08:34:23 UTC
Section 4.4.2, page 31, has the same problem:

As with linear volumes, you can specify the extents of the physical volume that you are using for the stripe. The following command creates a striped volume 100 extents in size that stripes across two physical volumes, is named stripelv and is in volume group testvg. The stripe will use sectors 0-50 of /dev/sda1 and sectors 50-100 of /dev/sdb1.

# lvcreate -l 100 -i2 -nstripelv testvg /dev/sda1:0-50 /dev/sdb1:50-100

should be corrected as:

As with linear volumes, you can specify the extents of the physical volume that you are using for the stripe. The following command creates a striped volume 100 extents in size that stripes across two physical volumes, is named stripelv and is in volume group testvg. The stripe will use sectors 0-49 of /dev/sda1 and sectors 50-99 of /dev/sdb1.

# lvcreate -l 100 -i2 -nstripelv testvg /dev/sda1:0-49 /dev/sdb1:50-99

Comment 3 Steven J. Levine 2010-12-21 21:08:51 UTC
I have fixed this in the working draft of the RHEL 6.1 version of the document, so it will be corrected at that release.

The same mistake was also in the RHEL 5 version of the document, so I have corrected that as well for the 5.6 release. Thanks.

Comment 4 Steven J. Levine 2011-01-20 19:56:35 UTC
Moving to MODIFIED since the updated text has been checked in to the svn repository.

Comment 7 Steven J. Levine 2011-05-24 18:44:06 UTC
With the release of RHEL 6.1, I am closing this bug.


Note You need to log in before you can comment on or make changes to this bug.