Bug 656241 - libvirt is not in dependency of rhn-virtualization
libvirt is not in dependency of rhn-virtualization
Status: CLOSED ERRATA
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Virtualization (Show other bugs)
540
Unspecified Unspecified
high Severity medium
: ---
: ---
Assigned To: Miroslav Suchý
Jiri Kastner
: Reopened
Depends On:
Blocks: sat54-errata
  Show dependency treegraph
 
Reported: 2010-11-23 05:22 EST by Petr Sklenar
Modified: 2013-03-09 22:17 EST (History)
5 users (show)

See Also:
Fixed In Version: rhn-virtualization-5.4.14-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-04-29 07:34:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Petr Sklenar 2010-11-23 05:22:54 EST
Description of problem:
libvirt should be installed and restarted on rhel6 host connected to sat540 when you check virtualization entitlement.

Version-Release number of selected component (if applicable):
sat540 + rhel6 host

How reproducible:
always

Steps to Reproduce:
1. have a machine installed with @base - there is no kvm, libvirt package
2. add virtualization entitlement
3. rhn_check on client 
4. create ks for virt guest and pick up this action on client
  
Actual results:
libvirt is missing

Expected results:
Installation of virt guest should start successfully.

libvirt is in dependency of rhn-virtualization and libvirtd is restarted.
kvm/qemu is also installed on client and it should be in dependencies.



Additional info:
Comment 2 Miroslav Suchý 2011-01-05 06:06:05 EST
Fixed in spacewalk.git as commit 0dc5b782d49fb286cb396a56a2682946b2f46b28
This change is for all system but RHEL5, where it will break RHEV. But there is no such problem anyway.

Additionally, after discussion with mzazrivec and jpazdziora I scratched the idea to have libvirtd (re)started after installation of rhn-virtualization-host. We never done it, and customers do not expect it.

We may change it in future if customer will request it or PM will specify this as new feature.
Comment 4 Miroslav Suchý 2011-01-06 09:05:06 EST
cherrypicked to satellite.git as commit 0f78b33db24d118988c4407e9571ae81459ef3e6
Comment 5 Jiri Kastner 2011-01-18 08:56:47 EST
rhn-virtualization.spec:
%if 0%{?rhel} && 0%{?rhel} < 6
# in RHEL5 we need libvirt, but in RHEV@RHEL5 there should not be libvirt
# as there is vdsm and bunch of other packages, but we have no clue how to
# distinguish those two scenarios
%else
Requires: libvirt
%endif

rpm -qpR rhn-virtualization-host-5.4.14-2.el6sat.noarch.rpm 
/bin/sh  
/bin/sh  
/bin/sh  
/bin/sh  
/usr/sbin/crond  
config(rhn-virtualization-host) = 5.4.14-2.el6sat
libvirt  
libvirt-python  
rhn-virtualization-common = 5.4.14-2.el6sat
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(FileDigests) <= 4.6.0-1
rpmlib(PartialHardlinkSets) <= 4.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(PayloadIsXz) <= 5.2-1

rpm -qpR rhn-virtualization-host-5.4.14-2.el5sat.noarch.rpm 
/bin/sh  
/bin/sh  
/bin/sh  
/bin/sh  
/usr/sbin/crond  
config(rhn-virtualization-host) = 5.4.14-2.el5sat
libvirt-python  
rhn-virtualization-common = 5.4.14-2.el5sat
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
Comment 6 errata-xmlrpc 2011-03-07 04:23:49 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0323.html
Comment 7 Giulio Fidente 2011-04-29 05:33:52 EDT
the solution provided with the errata introduces a problem where the RHEL5 hosts running as RHEV hypervisors gets libvirt installed by dependency, when they should not as this prevents vdsmd from starting at reboot
Comment 8 Miroslav Suchý 2011-04-29 07:34:53 EDT
Once bugzilla has assigned errata, which is released it should not be reopen. Please create new BZ, or clone this one to new.
I'm closing it again.

And btw - rhn-virtualization require libvirt only in RHEL6. It does *not* require it on RHEL5.
Comment 9 Giulio Fidente 2011-05-03 09:43:47 EDT
please excuse me for reopening the bug report, in comment #6 there was a line saying "You may reopen this bug report if the solution does not work for you.", that's why I did it

btw, the problem is that I _do_ get libvirt installed by dependency even on RHEL5, where it can cause conflicts with vdsmd if that is installed

yum install rhn-virtualization-host

tries to install:

rhn-virtualization-host 5.4.14-3.el5sat

which for some reasons brings in:

libvirt 0.8.2-15.el5_6.4

and also
cyrus-sasl-md5
e4fsprogs-libs
ebtables
libvirt-python
rhn-virtualization-common
xen-libs
xz
xz-libs

Note You need to log in before you can comment on or make changes to this bug.