Bug 656246 (CVE-2010-4172) - CVE-2010-4172 tomcat: cross-site-scripting vulnerability in the manager application
Summary: CVE-2010-4172 tomcat: cross-site-scripting vulnerability in the manager appli...
Keywords:
Status: CLOSED ERRATA
Alias: CVE-2010-4172
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 656402 656403 656405 656406 669463
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-11-23 10:30 UTC by Marc Schoenefeld
Modified: 2019-09-29 12:41 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-06-18 06:01:53 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHSA-2011:0791 normal SHIPPED_LIVE Moderate: tomcat6 security and bug fix update 2011-05-19 10:58:07 UTC
Red Hat Product Errata RHSA-2011:0896 normal SHIPPED_LIVE Moderate: JBoss Enterprise Web Server 1.0.2 update 2011-06-22 23:16:28 UTC
Red Hat Product Errata RHSA-2011:0897 normal SHIPPED_LIVE Moderate: JBoss Enterprise Web Server 1.0.2 update 2011-06-22 23:38:13 UTC

Description Marc Schoenefeld 2010-11-23 10:30:39 UTC
A cross-site-scripting flaw was discovered in the manager application. It reflected the user provided parameters sort and orderBy directly without filtering applied.

The issue affects Tomcat 6 (impact=moderate):

From 6.0.12 to 6.0.29 and was fixed in r1037779:

http://svn.apache.org/viewvc?rev=1037779&view=rev

Upstream 6.0.30 will correct this flaw as noted:

http://tomcat.apache.org/security-6.html


The issue affects Tomcat 7 (impact=low, as caught by CSRF protection) : 
From 7.0.0 to 7.0.4 and was fixed in r1037778:

http://svn.apache.org/viewvc?rev=1037778&view=rev

Upstream 7.0.5 will correct this flaw as noted:

http://tomcat.apache.org/security-7.html

Comment 3 Vincent Danen 2011-01-13 18:21:19 UTC
Tomcat 6.0.30 has been released to fix this flaw:

http://tomcat.apache.org/security-6.html#Fixed_in_Apache_Tomcat_6.0.30

Comment 4 Vincent Danen 2011-01-13 18:23:47 UTC
Created tomcat6 tracking bugs for this issue

Affects: fedora-all [bug 669463]

Comment 7 errata-xmlrpc 2011-05-19 10:58:29 UTC
This issue has been addressed in following products:

  Red Hat Enterprise Linux 6

Via RHSA-2011:0791 https://rhn.redhat.com/errata/RHSA-2011-0791.html

Comment 9 Tomas Hoger 2011-06-09 12:04:06 UTC
Upstream announcement:
http://seclists.org/fulldisclosure/2010/Nov/283

Comment 10 errata-xmlrpc 2011-06-22 23:17:36 UTC
This issue has been addressed in following products:

  JBoss Enterprise Web Server 1.0

Via RHSA-2011:0896 https://rhn.redhat.com/errata/RHSA-2011-0896.html

Comment 11 errata-xmlrpc 2011-06-22 23:39:14 UTC
This issue has been addressed in following products:

  JBEWS 1.0 for RHEL 5
  JBEWS 1.0 for RHEL 4
  JBEWS 1 for RHEL 6

Via RHSA-2011:0897 https://rhn.redhat.com/errata/RHSA-2011-0897.html


Note You need to log in before you can comment on or make changes to this bug.