Bug 65626 - "ISR called reentrantly" error during stress testing
"ISR called reentrantly" error during stress testing
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-28 17:36 EDT by Roderick Constance
Modified: 2007-04-18 12:42 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-28 17:46:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/proc/interrupts (1.26 KB, text/plain)
2002-05-28 17:45 EDT, Roderick Constance
no flags Details
lspci (1.87 KB, text/plain)
2002-05-28 17:46 EDT, Roderick Constance
no flags Details
dmesg (17.93 KB, text/plain)
2002-05-28 17:46 EDT, Roderick Constance
no flags Details

  None (edit)
Description Roderick Constance 2002-05-28 17:36:57 EDT
Description of Problem:

I have a system configured with a LSI MegaRAID Elite 1600 and two Intel Dual 
EtherExpress Pro 100 PCI NICs.  The PCI devices are plugged into an "active" 3 
slot riser with built-in bridge chip.  The MegaRAID card is configured with a 
RAID 5 array over four Hitachi DK32DJ-36MC disks.  Each port on a NIC is 
configured to loopback to the corresponding port on the other NIC (i.e. port0 
on card0 is loopbacked to port0 on card1, and so on.).

When running a flood ping on each ethernet interface and a bonnie++ variant on 
the disks, the following kernel message comes up:

May 28 06:33:00 eng163 kernel: ISR called reentrantly!!

It usually apears a few at a time every 10-15 minutes.  This seems to be 
generated by the megaraid driver's interrupt service routine.  The megaraid 
and one of the ethernet interfaces share the same interrupt.  I haven't seen 
the problem occur when the disks are idle or when the ethernet interface 
(which shares the same interrupt) is idle.

The system has been stable and I haven't seen any filesystem problems or 
dropped packets.  Its been running for days with no problem except for the 
kernel message.

Version-Release number of selected component (if applicable):
RedHat 7.3 errata (2.4.18-4smp, megaraid.c v.1.18a)

How Reproducible:
Always

Steps to Reproduce:
1. induce heavy I/O load
2. 
3. 

Actual Results:
May 28 06:33:00 eng163 kernel: ISR called reentrantly!!

Expected Results:
No kernel message.

Additional Information:
Comment 1 Roderick Constance 2002-05-28 17:45:23 EDT
Created attachment 58789 [details]
/proc/interrupts
Comment 2 Roderick Constance 2002-05-28 17:46:12 EDT
Created attachment 58790 [details]
lspci
Comment 3 Roderick Constance 2002-05-28 17:46:45 EDT
Created attachment 58791 [details]
dmesg
Comment 4 Arjan van de Ven 2002-05-28 18:37:17 EDT
I've seen it too on my box, also never with hangs.
(but mostly with 2.4.9 kernels)

From doing some work on the driver it appears to be a race in the accounting of
this and it's just a stupid printk that triggers.... but the megaraid driver
isn't that great performance wise..... it needs a big cleanup/fixup

Note You need to log in before you can comment on or make changes to this bug.