Bug 65627 - System will not boot after upgrade
System will not boot after upgrade
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.3
athlon Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-28 18:24 EDT by Andrig T. Miller
Modified: 2007-04-18 12:42 EDT (History)
2 users (show)

See Also:
Fixed In Version: 2.4.18-5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-25 15:46:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrig T. Miller 2002-05-28 18:24:49 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0rc3) Gecko/20020523

Description of problem:
I get the following error when trying to boot after upgrading to RedHat 7.3:

 pivotroot: pivot_root(/sysroot,/sysroot/initrd) failed: 2
    Freeing unused kernel memory: 304k freed
    Kernel panic: No init found.  Try passing init= option to kernel.

I looked up this error message via Google, and found someone who had the same
problem, and said they fixed it by putting an empty /initrd directory back on
their system.  I checked for this condition, and found that I do indeed have an
empty /initrd directory.  This is a very severe problem, in that the upgrade
removed my working 2.4.9-31smp kernel for some reason.

I now have a working system.  I managed to do this by getting the old kernel
2.4.9-31smp on my system again.  I tried the newer 2.4.18-4smp kernel that
replaced the 2.4.18-3smp kernel but it didn't work either. 

My system is a dual processor Athlon (1.2 GHz), with a hardware RAID controller,
and an AIC7xxx SCSI controller as well.  I preload the following modules through
initrd to be able to boot:

DAC960
reiserfs
scsi_mod
aic7xxx
ext3

My root filesystem is reiserfs, and my /boot partition is ext3.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Upgrade from RedHat 7.2 to 7.3
2.Boot
	

Actual Results:   pivotroot: pivot_root(/sysroot,/sysroot/initrd) failed: 2
    Freeing unused kernel memory: 304k freed
    Kernel panic: No init found.  Try passing init= option to kernel.

Expected Results:  Root filesystem should have been mounted, and the remaining
portion of the boot process to get to runlevel 5 should have proceeded.

Additional info:
Comment 1 Chris Kloiber 2002-05-31 18:12:27 EDT
We have a customer <mitch@galaxytransport.com> (no bugzilla account at this
time) using ext3 on the root filesystem reporting the same error.
Comment 2 Mitch Loftus 2002-05-31 18:26:59 EDT
I am also using dual Pentium III's instead of Athlon
Comment 3 Arjan van de Ven 2002-06-05 06:05:30 EDT
Are you sure the order of the modules is the same before and after the upgrade ?
Also could you try using the aic7xxx_old module ?
Comment 4 Andrig T. Miller 2002-06-05 22:03:57 EDT
I am sure about the order of the modules.  The root filesystem happens to be on
the DAC960 hardware RAID controller, not on the Adaptec controller, so using the
older aic7xxx_old module will have no affect.  I preload aic7xxx and scsi_mod
only for my CDRW.  This is merely a convenience, and is not necessary for
booting.  My suspicion is that the DAC960 driver maybe were the problem is.
Comment 5 Arjan van de Ven 2002-06-06 03:34:13 EDT
Ok, I assume you are using grub? If so I think I know what the issue is; there's
an interaction between our 2.4.18, grub and dac960. lilo works. all other
controllers work with grub. but not dac960 and grub. I have a fix and we're
working on releasing an erratum.
Comment 6 Andrig T. Miller 2002-06-06 09:32:58 EDT
I am using Grub as the boot loader.  Thanks for looking into this.
Comment 7 Ian Dall 2002-08-26 08:45:59 EDT
I see precisely this problem but I don't have a DAC960.
This is a very ordinary uniprocessor system. The /boot and / are ext3
and the scsi controller is a sym53c875.
The system boots fine with an older kernel. I upgraded to 2.4.18-5 with no
change.
Comment 8 Andrig T. Miller 2002-09-13 22:29:32 EDT
This problem was fixed when I upgraded to the 2.4.18-5 kernel, but has come back
with the 2.4.18-10 kernel.  I am the original reporter on this, and I would
appreciate it if someone could check out whether the patch just wasn't put into
2.4.18-10.

Thanks.
Comment 9 Need Real Name 2002-11-25 19:09:40 EST
I have a client running Red Hat 7.2 on a Dell PowerEdge 2300 server.

I applied the kernel errata to change their kernel from stock (2.4.7-10) to the
latest security update, 2.4.18-18.

The system no longer boots. A blank init_module error is shown.

megaraid.o: init_module:
  insmod exited abnormally

other error messages I copied down were:

kmod: failed to exec /sbin/modprobe -s -k block-major-8, errno=2
mount: error 6 mounting ext3
pivotroot: pivot_root(/sysroot, /sysroot/initrd) failed: 2

I switched grub to boot the stock kernel instead. They however are eager to have
the security patches applied.


Booting dies with the same message as the original reporter here mentioned, no
init is found.
Comment 10 Need Real Name 2002-11-25 19:11:54 EST
Is there any way I can apply the 2.4.9-X kernel to this system in the mean time?
RHN says those packages are obsoleted by the 2.4.18-X kernels and won't let you
download them.
Comment 11 Charlie Brady 2003-06-03 15:24:02 EDT
I've just got the same symptoms, with the new erratum kernel - 2.4.20-18.7. My
platform is i686, not athlon, and is VMWare rather than metal.

...
VFS: Mounted root (ext2 filesystem)
Red Hat nash version 3.3.10 starting
Loading jbd module
Journalled Block Device driver loaded
Locading ext3 module
Mounting /proc filesystem
Creating root device
Mounting root filesystem
mount: error 6 mounting ext3
pivotroot: pivot_root(/sysroot,/sysroot/initrd) failed: 2
Freeing unused kernel memory: 120k freed
Kernel panic: No init found. Try passing init= option to kernel.

Note You need to log in before you can comment on or make changes to this bug.