Bug 6563 - Unable to detect or use Epson Stylus 740 with 6.1 installation.
Unable to detect or use Epson Stylus 740 with 6.1 installation.
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: printtool (Show other bugs)
6.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-10-31 02:25 EST by glenn
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-11-24 21:57:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description glenn 1999-10-31 02:25:10 EST
I have an epson stylus 740 printer interfaced to the
parallel port of a Pentium II system. Note that the printer
is interfaced to an Iomega drive that is itself connected
to the parallel port, but that even when the printer is
interfaced directly to the parallel port, rather than being
piggy-backed on the iomega, the result is the same.
Printtool fails to detect the device, which is on lpt1
under Windows. (Not detected on lp0 or lp1.) Attempts
to print ASCII directly to either port result in the
error message: couldn't write file "/dev/lp0": no such
device. Yet if I hook up an Epson EPL 6000 printer to the
same port in the same way, piggy-backed on the Iomega drive,
the port /dev/lp0 is detected and the test prints work.


The lpc status command gives the following output:

lp:
	queuing is enabled
	printing is enabled
	1 entry in spool area
	waiting for lp to become ready (offline ?)
lp0:
	queuing is enabled
	printing is enabled
	1 entry in spool area
	waiting for lp0 to become ready (offline ?)


The /etc/printcap file contains:

##PRINTTOOL3## LOCAL uniprint NAxNA letter {}
U_EpsonStylusColor stcany {}
lp:\
	:sd=/var/spool/lpd/lp:\
	:mx#0:\
	:sh:\
	:lp=/dev/lp1:\
	:if=/var/spool/lpd/lp/filter:
##PRINTTOOL3## LOCAL uniprint NAxNA letter {}
U_EpsonStylusColor stcany {}
lp0:\
	:sd=/var/spool/lpd/lp0:\
	:mx#0:\
	:sh:\
	:lp=/dev/lp0:\
	:if=/var/spool/lpd/lp0/filter:
Comment 1 Bill Nottingham 1999-11-01 11:12:59 EST
What happens if you remove the entry for it on /dev/lp1, and restart
lpd?

------- Additional Comments From   11/02/99 01:24 -------
Removing lp1 and restarting lpd had no effect. So I tried adding
the following lines to /etc/conf.modules:

alias parport_lowlevel parport_pc
options parport_pc io=0x378 irq=7,auto

Then I brought over some stylus 740 upp files for ghostscript,
and modified the printerdb file for rhs-printfilters as described
in http://lcewww.et.tudelft.nl/~haver/linux/epson.html. Then I
tried printing the PS test page from printtool on /dev/lp0.
This time lpc showed this print status:

lpc> stat
lp:
        queuing is enabled
        printing is enabled
        1 entry in spool area
        lp is ready and printing

When the print "finished", the print status was

lpc> status
lp:
	queuing is enabled
	printing is enabled
	no entries
	no daemon present

Unfortunately, there was no reponse from the printer. I would
attribute this problem to a faulty printer were it not for the
fact that it works without any difficulties under Windows 98.
Note that when I connect my old Epson EPL6000 to the same parallel
interface, it works.
Comment 2 Bill Nottingham 1999-11-09 12:54:59 EST
Have you upgraded to the errata lpr?
Comment 3 Bernhard Rosenkraenzer 1999-11-22 12:38:59 EST
If it still doesn't work with lpr 0.46 (errata) and 0.47 (rawhide), let us know.
Comment 4 glenn 1999-11-24 03:25:59 EST
Parallel printer port/printer still doesn't work with errata lpr (0.46),
and 0.47 doesn't yet appear to be available from Red Hat 6.1 customer
support web site.
Comment 5 glenn 1999-11-24 21:57:59 EST
I have found the problem, and it's not with RH6.1. The problem is that, for
reasons unknown to me, the Epson installation software for the Windows driver
("filter") for the Stylus 740 disables my parallel port, at least according to
the Bios Setup for my PC. It didn't occur to me that the setup utility could
show my parallel port as disabled even while Windows applications are able to
use the printer interfaced to the port. Once I assigned the address 0x3bc and
the IRQ=7 to this port, and thereby enabled it, RH6.1 had no trouble detecting
my printer, and the printer itself now works fine with the generic Stylus color
UP filter provided with RH6.1. Thanks for your help, and I hope that you'll
excuse me for not getting to the bottom of this sooner.

Note You need to log in before you can comment on or make changes to this bug.