Bug 656387 - xorg-x11-drv-evdev is not usable for Xen PV guests
xorg-x11-drv-evdev is not usable for Xen PV guests
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xorg-x11-drv-evdev (Show other bugs)
5.5
Unspecified Unspecified
low Severity medium
: rc
: ---
Assigned To: Peter Hutterer
desktop-bugs@redhat.com
: Patch, Triaged
Depends On:
Blocks: 656468
  Show dependency treegraph
 
Reported: 2010-11-23 11:15 EST by john.haxby@oracle.com
Modified: 2014-06-09 07:06 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-02 09:17:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Patch to allow xorg-x11-drv-evdev to be used for the xen mouse (9.79 KB, patch)
2010-11-23 11:15 EST, john.haxby@oracle.com
no flags Details | Diff
rhpxl patch to allow xen mouse configuration with system-config-display (3.37 KB, patch)
2010-11-23 11:25 EST, john.haxby@oracle.com
no flags Details | Diff

  None (edit)
Description john.haxby@oracle.com 2010-11-23 11:15:41 EST
Created attachment 462377 [details]
Patch to allow xorg-x11-drv-evdev to be used for the xen mouse

Description of problem:

   If you try to configure xorg-x11-drv-evdev so that you can make use of
   absolute pointer events for Xen PV guests (which is the correct thing to
   do) you quickly run up against a problem because the driver takes over both
   the mouse and the keyboard and while you can have absolute pointer events
   you can't have keyboard events.

Version-Release number of selected component (if applicable):
   xorg-x11-drv-evdev-1.0.0.5-5.el5

How reproducible:
   Always

Steps to Reproduce:
1.  Attempt to configure xorg-x11-drv-evdev for the absolute mouse pointer
    for a Xen PV guest.  (Note that some releases of the Xen hypervisor will
    also frustrate this because they take no notice when xenkbd.abs_pointer=1
    is passed on the guest's kernel command line).
  
Actual results:
  Discover that it is not possible to have both absolute mouse events and
  a working keyboard.

Expected results:
  Working absolute mouse pointer events *and* a working keyboard.

Additional info:
  The attached patch allows you have a mouse pointer configuration like this:

     Section "InputDevice"
           Identifier  "xenmouse"
           Driver      "evdev"
           Option      "DeviceName" "xen.*(mouse|pointer)"
           Option      "IgnoreKeyboard" "True"
           Option      "WarnOnRelative" "True"
           Option      "GrabDevice" "False"
           Option      "SendCoreEvents" "True"
     EndSection

   The DeviceName, IgnoreKeyboard, WarnOnRelative and GrabDevice options are
   all new.  DeviceName allows the driver to scan /dev/input/event* looking
   for a device that matches a pattern which allows this patch to work with
   kernels that supply different drivers and name the xen mouse driver
   differently.

   IgnoreKeyboard means that the the driver ignores keyboard events coming
   from /dev/input/evdev?  (For completeness there is an IgnoreMouse option)

   WarnOnRelative is an option to print a suitable warning message to
   the Xorg log file if the driver detects relative pointer events (this helps
   tremendously when trying to work out why it isn't working)

   Finally GrabDevice allows events to be handled by other devices, in this
   case the normal keyboard driver.

   The default values for all of these are such that xorg-x11-drv-evdev is
   fully backwards compatible.
Comment 1 john.haxby@oracle.com 2010-11-23 11:25:54 EST
Created attachment 462380 [details]
rhpxl patch to allow xen mouse configuration with system-config-display

Configuring the xen mouse by hand is tedious.  This patch for rhpxl allows you to just run "system-config-display --reconfig" to handle all the necessary reconfiguration.  If a Xen mouse is detected it ands an input device stanza like this to your /etc/X11/xorg.conf:

        Section "InputDevice"
                Identifier  "xenmouse"
                Driver      "evdev"
                Option      "DeviceName" "xen.*(mouse|pointer)"
                Option      "IgnoreKeyboard" "True"
                Option      "WarnOnRelative" "True"
                Option      "GrabDevice" "False"
                Option      "SendCoreEvents" "True"
        EndSection

I also sneaked in a minor fix that lost the keyboard defined in /etc/sysconfig/keyboard.
Comment 2 Vladimir Benes 2010-11-23 11:36:15 EST
rhpxl is on approved components list, do not know if we want to add it into 5.6 as there is still no erratum filed.
Comment 3 john.haxby@oracle.com 2010-11-23 11:53:25 EST
I haven't seen the 5.6 beta yet -- has rhpxl been removed?  I'm not sure I understand your comment. Do you want me to add a separate bug dependent on this one for rhpxl?
Comment 4 Vladimir Benes 2010-11-23 12:45:11 EST
Definitely two bugs should be filed, one for evdev and the second one for rhpxl. We need to wait for patch review from developer and then see if this can be incorporated into RHEL5.6 but I doubt it will as it's quite late in the cycle. So please file rhpxl bug and then wait for developer opinion. 

Thank you.
Comment 5 john.haxby@oracle.com 2010-11-23 14:51:52 EST
OK.  The rhpxl bug is 656468 (and is dependent on this bug of course).
Comment 7 Matěj Cepl 2010-11-29 05:46:26 EST
Nothing to triage here.
Comment 8 RHEL Product and Program Management 2014-03-07 08:42:53 EST
This bug/component is not included in scope for RHEL-5.11.0 which is the last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your account manager or support representative in case you need to escalate this bug.
Comment 9 RHEL Product and Program Management 2014-06-02 09:17:29 EDT
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in RHEL5 stream. If the issue is critical for your business, please provide additional business justification through the appropriate support channels (https://access.redhat.com/site/support).
Comment 10 john.haxby@oracle.com 2014-06-09 07:06:26 EDT
I'm not sure why this is marked as NEEDINFO from me when it's CLOSED WONTFIX

Note You need to log in before you can comment on or make changes to this bug.