Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 656514 - [abrt] alsa-tools-1.0.23-1.fc14: Process /usr/bin/hdspmixer was killed by signal 11 (SIGSEGV)
Summary: [abrt] alsa-tools-1.0.23-1.fc14: Process /usr/bin/hdspmixer was killed by sig...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: alsa-tools
Version: 14
Hardware: x86_64
OS: Unspecified
low
medium
Target Milestone: ---
Assignee: Tim Jackson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:04cb4aa96494f88e876e78452b4...
: 566138 669188 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-11-23 22:13 UTC by Fred Q.
Modified: 2011-02-15 00:45 UTC (History)
5 users (show)

Fixed In Version: alsa-tools-1.0.24.1-1.fc14
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-02-13 08:55:45 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (5.74 KB, text/plain)
2010-11-23 22:13 UTC, Fred Q.
no flags Details

Description Fred Q. 2010-11-23 22:13:46 UTC
abrt version: 1.1.14
architecture: x86_64
Attached file: backtrace
cmdline: hdspmixer
component: alsa-tools
crash_function: Fl_Preferences::RootNode::~RootNode
executable: /usr/bin/hdspmixer
kernel: 2.6.35.6-48.fc14.x86_64
package: alsa-tools-1.0.23-1.fc14
rating: 4
reason: Process /usr/bin/hdspmixer was killed by signal 11 (SIGSEGV)
release: Fedora release 14 (Laughlin)
time: 1290547953
uid: 500

How to reproduce
-----
1.install realtek hd drivers
2.reboot system
3.

Comment 1 Fred Q. 2010-11-23 22:13:48 UTC
Created attachment 462465 [details]
File: backtrace

Comment 2 Fernando Lopez-Lezcano 2010-12-13 02:08:55 UTC
I can confirm that hdspmixer (mixer for RME soundcards) segfaults (both fc13 and fc14 have this problem). I have released a package with a fix as part of Planet CCRMA as RME high end soundcards are used more often by pro audio users. 

(this has (AFAIK) nothing to do with the realtek hd drivers - to reproduce it is enough to try to start hdspmixer). 

Here is the patch (originally from Gentoo) that I have used to successfully resolve this issue:

--- alsa-tools-1.0.23/hdspmixer/src/HDSPMixerIOMixer.h	2010-04-16 13:11:09.000000000 +0200
+++ alsa-tools-1.0.23-work/hdspmixer/src/HDSPMixerIOMixer.h	2010-05-12 22:07:49.549949993 +0200
@@ -36,6 +36,7 @@
 #include "HDSPMixerStripData.h"
 #include "HDSPMixerMeter.h"
 #include "pixmaps.h"
+#include <sstream>
 
 class HDSPMixerWindow;
 class HDSPMixerSelector;
@@ -52,7 +53,7 @@
 private:
     char **p_iomixer_xpm;
     int channel_num, relative_num, mixer_type;
-    char channel_name[6];
+	std::stringstream channel_name;
     void update_child(Fl_Widget &widget);
 public:
     HDSPMixerStripData *data[3][3][8]; /* data[card][mode(ss/ds/qs)][preset number] */
--- alsa-tools-1.0.23/hdspmixer/src/HDSPMixerIOMixer.cxx	2010-04-16 13:11:09.000000000 +0200
+++ alsa-tools-1.0.23-work/hdspmixer/src/HDSPMixerIOMixer.cxx	2010-05-12 22:00:26.754950707 +0200
@@ -25,9 +25,9 @@
 {
     mixer_type = type;
     if (type) {
-	sprintf(channel_name, "Out %d", ch);
+	channel_name << "Out " << ch;
     } else {
-	sprintf(channel_name, "In %d", ch);
+	channel_name << "In " << ch;
     }
     channel_num = ch;
     if (channel_num%2) {
@@ -73,7 +73,7 @@
 	draw_background();
 	fl_color(FL_BLACK);
 	fl_font(FL_HELVETICA, 8);
-	fl_draw(channel_name, x()+4, y()+225, 27, 9, FL_ALIGN_CENTER);
+	fl_draw(channel_name.str().c_str(), x()+4, y()+225, 27, 9, FL_ALIGN_CENTER);
 	for (int i=children(); i--;) {
 	    Fl_Widget& o = **a++;
 	    draw_child(o);

Comment 3 Tim Jackson 2011-02-02 17:27:05 UTC
*** Bug 669188 has been marked as a duplicate of this bug. ***

Comment 4 Tim Jackson 2011-02-02 18:29:48 UTC
Package fixed for F-13 at https://admin.fedoraproject.org/updates/alsa-tools-1.0.23-2.fc13
alsa-tools-1.0.24.1 (which contains the fix) is forthcoming for F-14+

Comment 5 Fedora Update System 2011-02-03 18:14:53 UTC
alsa-tools-1.0.24.1-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/alsa-tools-1.0.24.1-1.fc14

Comment 6 Tim Jackson 2011-02-03 21:44:18 UTC
*** Bug 566138 has been marked as a duplicate of this bug. ***

Comment 7 Fedora Update System 2011-02-13 08:55:39 UTC
alsa-tools-1.0.24.1-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 8 Hugues Thiébaux 2011-02-15 00:45:48 UTC
After updating to alsa-tools-1.0.24.1-1.fc14, my card is no more recognized when launching hdspmixer:

Looking for RME cards :
Card 0 : RME Hammerfall HDSP 9652 at 0xfbff0000, irq 16
Card 1 : HDA NVidia at 0xfbe7c000 irq 16
No RME cards found.

I reverted to alsa-tools-1.0.23-1.1.fc14.ccrma.x86_64 with:
yum downgrade alsa-tools 

And launching hdspmixer now says: 

Looking for HDSP cards :
Card 0 : RME Hammerfall HDSP 9652 at 0xfbff0000, irq 16
HDSP 9652 found !
Card 1 : HDA NVidia at 0xfbe7c000 irq 16
1 Hammerfall DSP card found.
Restoring last presets used


Note You need to log in before you can comment on or make changes to this bug.