Bug 656529 - Unhandled exception for Network GUI
Summary: Unhandled exception for Network GUI
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: system-config-network
Version: 5.5
Hardware: x86_64
OS: Linux
low
high
Target Milestone: rc
: ---
Assignee: Harald Hoyer
QA Contact: Branislav Blaškovič
URL:
Whiteboard:
Depends On:
Blocks: 1049888
TreeView+ depends on / blocked
 
Reported: 2010-11-23 22:43 UTC by Sudeep Joshi
Modified: 2014-09-16 00:17 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Early versions of the Python programming language do not switch to the UTF-8 format correctly. This behavior led to a failure of the system-config-network service when some UTF-8 character were present in configuration files. With this update, system-config-network now resets the Python internals to properly handle UTF-8 so that system-config-network no longer crashes in the described scenario.
Clone Of:
Environment:
Last Closed: 2014-09-16 00:17:49 UTC
Target Upstream Version:


Attachments (Terms of Use)
Crash dump file for network gui (4.65 KB, text/plain)
2010-11-23 22:43 UTC, Sudeep Joshi
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1195 0 normal SHIPPED_LIVE system-config-network bug fix update 2014-09-16 04:14:20 UTC

Description Sudeep Joshi 2010-11-23 22:43:31 UTC
Created attachment 462475 [details]
Crash dump file for network gui

Description of problem:
Receiving unhandled exception when I open the 
Network GUI.
Version-Release number of selected component (if applicable):

5.3
How reproducible:

Everytime by going to System> Administration> Network icon from the task bar.
Steps to Reproduce:
1. Click on System
2. Click on Administration
3. Click on Network
  
Actual results:
Unhandled exception of the gui

Expected results:
Network GUI to change the IP address

Additional info: NA

Comment 1 Harald Hoyer 2010-11-24 09:51:41 UTC
Please update your system..

http://rhn.redhat.com/errata/RHBA-2009-1352.html

Comment 2 iranna 2011-04-05 11:19:16 UTC
(In reply to comment #1)
> Please update your system..
> 
> http://rhn.redhat.com/errata/RHBA-2009-1352.html

what i have to update?

Comment 3 Harald Hoyer 2011-04-06 09:01:58 UTC
(In reply to comment #2)
> (In reply to comment #1)
> > Please update your system..
> > 
> > http://rhn.redhat.com/errata/RHBA-2009-1352.html
> 
> what i have to update?

# yum update system-config-network

Comment 4 Robert Gervais 2012-06-02 13:31:56 UTC
I have the same problem with the following version

Installed Packages
Name       : system-config-network
Arch       : noarch
Version    : 1.3.99.21
Release    : 1.el5
Size       : 2.3 M
Repo       : installed
Summary    : Interface graphique de l'outil d'administration r?au
URL        : http://fedora.redhat.com/projects/config-tools/redhat-config-network.html
License    : GPL
Description: Ceci est l'interface graphique de l'outil de configuration r?au,
           : qui prend en charge Ethernet, Wireless, TokenRing, ADSL, ISDN et PPP.

Comment 5 Robert Gervais 2012-06-02 15:37:09 UTC
I found the problem...

As I'm french Canadian I used french(Canada) as session language.

And it seems that there is a bug with utf-8 Codec...

If I use english-canadian all works fine

Comment 9 Branislav Blaškovič 2014-05-15 12:01:33 UTC
Testing command: LANG=fr_CA.utf8 system-config-network

Reproduced using:
system-config-network-1.3.99.21-1.el5

Working with:
system-config-network-1.3.99.22-1.el5

Comment 11 errata-xmlrpc 2014-09-16 00:17:49 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1195.html


Note You need to log in before you can comment on or make changes to this bug.