Bug 656562 - Please Update Spec File to use %ghost on files in /var/run and /var/lock
Summary: Please Update Spec File to use %ghost on files in /var/run and /var/lock
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: condor   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Timothy St. Clair
QA Contact: Fedora Extras Quality Assurance
URL: http://lists.fedoraproject.org/piperm...
Whiteboard:
Keywords:
Depends On:
Blocks: 827166
TreeView+ depends on / blocked
 
Reported: 2010-11-23 23:26 UTC by Lennart Poettering
Modified: 2012-05-31 19:39 UTC (History)
4 users (show)

Fixed In Version: condor-7.7.3-0.2.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-11-25 02:09:17 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Lennart Poettering 2010-11-23 23:26:18 UTC
Your package condor appears to include a file in /var/run or /var/lock. With an upcoming change in Rawhide these directories will now be mounted as tmpfs. For details about this change please consult http://lists.fedoraproject.org/pipermail/devel-announce/2010-November/000726.html For your package this means that you need add %ghost to all files that are placed in either of these two directories. Please make sure to make this change in time for the F15 cycle. For details about %ghost see http://www.rpm.org/max-rpm-snapshot/s1-rpm-inside-files-list-directives.html#S3-RPM-INSIDE-FLIST-GHOST-DIRECTIVE , for more information on the F15 feature see the feature page https://fedoraproject.org/wiki/Features/var-run-tmpfs . If your package already uses %ghost on these files, feel free to close this bug report right-away. Sorry for this mass bug filing, and if you have any further questions, don't hesitate to ask on fedora-devel or ask me personally. Thank you, Lennart

Comment 1 Thomas Spura 2011-08-20 10:27:29 UTC
Any news here?

The "files" in question are:

%dir %_var/lock/condor/
%dir %_var/run/condor/

Comment 2 Matthew Farrellee 2011-08-20 18:20:50 UTC
It looks like we aren't %ghost'ing, but we do provide a tmpfiles.conf.

Brian, will you take a look at this?

Comment 3 Timothy St. Clair 2011-10-26 17:43:19 UTC
The following says "not to" do this for directories:
https://fedorahosted.org/fesco/ticket/525

Comment 4 Matthew Farrellee 2011-11-08 03:54:30 UTC
(In reply to comment #3)
> The following says "not to" do this for directories:
> https://fedorahosted.org/fesco/ticket/525

%ghost'ing (7.7.1-0.1) appears to be a problem because /var/run/condor will not exist between install and system reboot. The result is the condor_procd failing and any daemons relying on it (condor_schedd, condor_startd) will not run without manual intervention of,

sudo mkdir /var/run/condor
sudo chown condor.condor /var/run/condor

Comment 5 Fedora Update System 2011-11-12 03:38:21 UTC
condor-7.7.3-0.2.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/condor-7.7.3-0.2.fc15

Comment 6 Fedora Update System 2011-11-13 05:36:45 UTC
Package condor-7.7.3-0.2.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing condor-7.7.3-0.2.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2011-15855
then log in and leave karma (feedback).

Comment 7 Fedora Update System 2011-11-25 02:09:17 UTC
condor-7.7.3-0.2.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.